
Version 1.0.2 ©2014 MotiveWave™ Software Page 1 of 190 

 

MotiveWave ™ 
User’s Guide 

Version: 1.0.2 
 

©2014 MotiveWave™ Software 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 2 of 190 

 

Table of Contents 

1 Introduction 6 

1.1 MotiveWave™ Editions and Modules 6 

1.1.1 Editions 6 

1.1.2 Modules 6 

1.2 Starting MotiveWave™ 6 

1.3 License 7 

1.3.1 Changing your License Key 7 

1.3.2 License Status 8 

2 Console 10 

2.1 Preferences 14 

2.2 Workspaces 15 

2.3 Changing the Default Layout 17 

2.3.1 Creating a new page 17 

2.3.2 Modifying a Page 18 

2.3.3 Changing the Page Order 19 

2.3.4 Resizing Panels 19 

2.3.5 Adding New Panel Tabs 20 

2.3.6 Creating a Custom Layout 20 

2.4 Changing the Look and Feel 21 

2.5 Instruments 23 

2.5.1 Importing Instruments 24 

2.5.2 Trading Hours 24 

2.6 Watch Lists 27 

2.6.1 Watch List Tool Bar 27 

2.6.2 Sorting Options 28 

2.6.3 Buy/Sell Boxes 29 

2.6.4 Create Watch List 31 

2.6.5 Edit Watch List 32 

2.7 Quote Sheets 34 

2.8 Backup/Restore 36 

2.8.1 Creating a Backup 36 

2.8.2 Restore From Backup 37 

2.9 Repository 38 

2.9.1 Sharing using Google Drive or Drop Box 40 

2.9.2 Folder Structure 40 

2.9.3 Analysis Sources 41 

2.10 Email Configuration 43 

2.10.1 Gmail 44 

2.10.2 Yahoo Mail 44 

2.10.3 Windows Live / Hotmail 44 

3 Charts 45 

3.1 Settings 45 

3.1.1 Default Chart Settings and Options 45 

3.1.2 Chart Specific Settings 49 

3.2 Price Indicators 49 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 3 of 190 

 

3.3 Chart Spacing 50 

3.4 Bar Sizes 51 

3.4.1 Custom Bar Sizes 52 

3.4.2 Bar Size Selector 52 

3.5 Importing Data 54 

3.6 Exporting Data 55 

3.7 Bird’s Eye View 56 

3.8 Cursor Data 57 

3.8.1 Cursor Data Window 57 

3.8.2 Cursor Data Panel 58 

3.8.3 Bar Status 58 

3.8.4 Hover Popup 59 

3.8.5 Cross Hair 59 

3.9 Time & Sales 61 

3.10 Depth Of Market (DOM) Panel 62 

3.11 Chart Labels 62 

3.12 News 64 

3.13 Watermark 65 

3.14 Scaling 66 

3.15 Analyses 67 

3.15.1 Creating a New Analysis 68 

3.15.2 Open Existing Analysis 69 

3.15.3 Manage Analyses 70 

3.15.4 Import/Export Analyses 70 

3.16 Components 71 

3.16.1 Components Panel 71 

3.16.2 Adding a Component 72 

3.16.3 Selecting Components 73 

3.16.4 Deleting a Component 75 

3.16.5 Component Properties 75 

3.16.6 Working with Trend Lines 76 

3.16.7 Visibility 80 

3.16.8 Object Viewer 81 

3.17 Ratios 81 

3.17.1 Customized Ratios 83 

3.17.2 Ratio Preferences 84 

3.17.3 Ratio Presets 84 

3.17.4 Global Ratio Preferences 85 

3.18 Time/Price Guides 88 

3.19 Percent Change Charts 89 

3.20 Studies 91 

3.20.1 Adding a Study 92 

3.20.2 Editing a Study 93 

3.20.3 Study Options 94 

3.20.4 Signals 97 

3.20.5 Instrument Overlay 98 

andrey
tr-soft-catalog



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 4 of 190 

 

3.21 Strategies 101 

3.21.1 Manual Strategies 102 

3.21.2 Strategy Configuration 104 

3.22 Software Development Kit (SDK) 106 

3.23 Tool Bar 106 

3.24 Lock Studies 107 

3.25 Lock Scroll 108 

3.26 Study Templates 109 

3.26.1 Removing a Template 111 

3.26.2 Managing Templates 112 

3.26.3 Template Preferences 112 

3.27 Linking Charts 113 

3.27.1 Linking With Templates 114 

3.27.2 Link All 115 

3.28 Working with Chart Windows 115 

3.28.1 Compact Mode 115 

3.28.2 Tile Windows 116 

3.28.3 Cascade Windows 117 

3.28.4 Window Sizes 118 

3.29 Replay Mode 119 

3.29.1 Replay Settings 120 

3.29.2 Linking in Replay Mode 121 

3.30 Alerts 122 

3.30.1 Price Alerts 123 

3.30.2 Study Alerts 124 

3.30.3 Component Alerts 126 

3.30.4 Trading From Alerts 128 

3.30.5 Advanced Alert Settings 128 

3.30.6 Alert History 129 

3.30.7 Alert Preferences 130 

3.31 Ticker Tape 131 

3.32 Short Cuts 132 

3.32.1 Menu Short Cut Keys 132 

3.32.2 Mouse Wheel 133 

3.32.3 Mouse Click Options 134 

3.32.4 Other Shortcuts 135 

4 Trading 137 

4.1 Account Management 137 

4.1.1 Accounts Panel 138 

4.1.2 Orders Panel 139 

4.1.3 Positions Panel 140 

4.1.4 Trades Panel 141 

4.2 Simulated Account 142 

4.3 Commissions 143 

4.4 Order Presets 144 

4.5 Chart Trading 146 

andrey
tr-soft-catalog



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 5 of 190 

 

4.5.1 Chart Orders 146 

4.5.2 Trade History 148 

4.5.3 Price Axis Trading 148 

4.5.4 Buy/Sell Buttons 151 

4.5.5 Context Menu 152 

4.5.6 Trade Panel 152 

4.5.7 Preferences 158 

4.6 Depth Of Market (DOM) 159 

4.6.1 Trading From the DOM 160 

4.6.2 Position Panel 162 

4.6.3 Centering 163 

4.6.4 Preferences 163 

4.7 Option Chains 164 

4.7.1 Placing and Managing Orders 165 

4.7.2 Preferences 166 

5 Chart Groups 168 

5.1 Changing Chart Group Layout 170 

6 Scanner 171 

6.1 Creating a Scan (Gartley Scanner) 171 

6.2 Executing a Scan 173 

6.3 Editing a Scan 174 

6.4 Elliott Wave Scanner 175 

6.5 Study Scanner 177 

7 Strategy Back Testing 183 

7.1 Creating a Strategy Analysis 183 

7.1.1 Strategy Settings Panel 184 

7.1.2 Choose Instruments Panel 185 

7.1.3 Data Settings Panel 186 

7.1.4 Execution Settings Panel 187 

7.1.5 Optimizer Settings Panel 187 

7.2 Strategy Analysis 189 

andrey
tr-soft-catalog

andrey
tr-soft-collection



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 6 of 190 

 

1 Introduction 

Welcome to the MotiveWave™ User’s Guide!  If you are reading this document then you have already 
installed MotiveWave™ on your computer and you are ready to start using the application. 

If you have not yet installed MotiveWave™ or registered for a trial on our website, please read the 
Installation Guide before continuing on with this document. 

1.1 MotiveWave™ Editions and Modules 

If you are currently working with the trial version of MotiveWave™ (available from our website), then 
you most likely have the Ultimate Edition of MotiveWave™.  This edition includes all of our features and 
functionality.  If you are currently on a trial and you would like to try a specific edition/module, please 
contact sales@motivewave.com. 

1.1.1 Editions 

There are several editions of MotiveWave™ available to address the different needs and budgets of 
traders and market analysts.   Detailed information on these editions and the functionality that they 
provide can be found on our website: http://www.motivewave.com/purchase/compare-editions.htm 

1. Ultimate Edition – This edition includes all of our features and is recommended if you are a 
professional trader and you are using advanced features such as Elliott Wave, Gann or Gartley.  

2. Professional Edition – This is for professional traders that do not used advanced features such as 
Elliott Wave, Gann or Gartley 

3. Trade Edition – Expands on the Analyst Edition to provide trading capabilities  
4. Analyst Edition – This entry level edition contains a full set of studies and basic tools for doing 

analysis. 

1.1.2 Modules 

Modules can be added to editions to extend their capabilities.  For a full list of available modules and 
their capabilities see: http://www.motivewave.com/purchase/modules.htm 

1.2 Starting MotiveWave™ 

If you are on Mac OSX™, MotiveWave ™ will be found from your Launch Pad or in your Applications 
folder.  Just click on the MotiveWave™ icon to start the application.   If you installed MotiveWave™ on a 
Windows™ machine double click on the MotiveWave™ icon on your desktop.  Alternatively, choose Start 
-> All Programs -> MotiveWave -> MotiveWave.exe 

The first screen that you will see when you start MotiveWave is the startup screen.  Normally you will 
open a workspace from this screen.  Select the workspace from the drop down and press the Continue 
button. 
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MotiveWave™ Startup Screen 

 

Depending on the broker or data service that you have chosen for the workspace, you may see a dialog 
that asks for login information.  The example below is a login dialog for an FXCM workspace. In this case 
enter your User ID and password for your FXCM account. 

Please Note: there is no user name or password for MotiveWave™, just a license key.  If you are being 
asked for a login ID and password, then this would be for the broker or data service that you chose for 
the workspace. 

FXCM Login Dialog 

 

1.3 License 

When you create a trial for MotiveWave™ from our website, you will be sent an email that contains a 
license key.   This key will need to be entered as part of the installation process (see the Install Guide).  
This license key uniquely identifies your profile and will not change (even when you purchase).  

If you think this key has been compromised, you can send a request to our support team 
(support@motivewave.com) to request a new key.  This key will be sent to the email address that you 
registered with. 

1.3.1 Changing your License Key 

Your license key can be changed from the startup screen in MotiveWave™.  Click on the Options button, 
then click on the License button. 
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Update License 

 

Enter your new license key into the License Key field.  Press the Update button to validate this key and 
change the license key that MotiveWave™ will use going forward.  Note: to avoid mistyping the license 
key, it is recommended that you copy and paste the key from the email message instead. 

Update License Dialog 

 

1.3.2 License Status 

You can easily check which MotiveWave™ Edition and Modules that are assigned to your license by 
choosing Help -> About from the top menu bar of the Console.   The About dialog will display your 
license key, email address, edition, modules and lease/support expiry dates. 

Check License Information 
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About Dialog 
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2 Console 

After you have installed MotiveWave™ and configured your workspace the first window that you will see 
when opening that workspace will be the Console.  The console provides access to all the features in 
MotiveWave™ and it is initially configured with a default layout. 

Default Console Layout 

 

The console is organized into different pages (see screen shot above, please note: pages are only 
available in the Professional and Ultimate editions of MotiveWave™).   To access a different page, simply 
click on the page tab at the bottom of the console window.  The default set of pages are as follows: 

1. Home – The home page contains a sample layout that has a single chart area and two spots at 
the bottom for watch lists. 

2. Charts – Sample layout of 6 charts 
3. Account – Layout containing information about your account, orders, positions and historical 

trades. 
4. Options – Sample layout containing Option Chains.  Note: this page is only available on brokers 

that support options trading. 
5. Scan – Layout for using the scanning functionality within MotiveWave™ 
6. Optimize – Contains a strategy optimizer panel for Back Testing, Optimization and Walk Forward 

testing of automated strategies. 
7. News – If supported by your Broker/Data service, you may see a page for news 

The following screen shots illustrate the default set of pages in the console: 
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Charts Page 

 
Accounts Page 
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Options Page 

 
Scan Page 
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Optimize Page 
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News Page 

 

2.1 Preferences 

The Preferences Dialog (choose Configure -> Preferences from the Console menu bar) provides a 
centralized location for configuring MotiveWave™.  This dialog contains many configuration panels 
organized under tabs (and sub tabs). 

Preferences 
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Preferences Dialog 

 

Feel free to explore the configuration options within MotiveWave™ by looking at the tabs and sub tabs 
available in this dialog.  More detail on specific configuration options can be found in other parts of this 
document. 

2.2 Workspaces 

Connections to Brokers and Data Services are managed through workspaces.  Each workspace is a 
separate instance of MotiveWave™ and contains its own local database.  All data, settings and analyses 
are separate between each workspace. 

Workspaces can be managed from the Console or from the startup screen (click on the Options button 
then on the Workspaces button). 

Manage Workspaces from Startup Screen 
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Manage Workspaces from the Console menu bar  

 

The Manage Workspaces dialog enables you to create new workspaces or to edit/modify existing 
workspaces.  The order in which they appear in the startup workspace drop down can also be modified 
from this dialog.  Click on the New Workspace button to create a new workspace. 

Manage Workspaces Dialog 

 

The Create Workspace dialog enables you to choose a workspace name and choose a broker or data 
service.  The settings for each broker or data service will be different.  A help pane on the right hand side 
will display specific information on the selected service. 
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Create Workspace Dialog 

 

2.3 Changing the Default Layout 

The console layout is highly configurable.  All pages can have their layouts modified and pages can be 
added or removed.  The following screen shot illustrates the page area and some of the available 
options: 

Page Area 

 

2.3.1 Creating a new page 

To add a page to the console, click on the New Page button (see above).   The New Page dialog will 
appear (see below).  You will need to specify a name for your page.  This name is displayed on the page 
tab when it is added to the console. 

There are many different layouts available for your page.  Just choose the one that most closely matches 
what you want to have on the page.  Several categories are available in the tabs at the top of the dialog.  
The icon matching the category will be displayed on the page tab that you are creating (making it easier 
to identify). 
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New Page Dialog 

 

2.3.2 Modifying a Page 

You can change the name of a page and optionally its layout.  To modify the current page, click on the 
Edit Page button on the right hand side of the page area. 

 

This will open the Edit Page dialog where you can change the name of the page and optionally select a 
new layout for the page.   

At the bottom of the Edit Page dialog you will see a button called Reset Layout.  This button can be used 
to reset the console layout to the default.  This will reset all of the pages including their layouts to be the 
same as when you first created the workspace (see Default Console Layout screen shot). 
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Edit Page Dialog 

 

2.3.3 Changing the Page Order 

If you would like to change the order of the pages, simply click and drag the page tab to the desired 
location: 

Change Page Order 

 

2.3.4 Resizing Panels 

The size of the panels displayed in a page can be resized by clicking and dragging the area between each 
panel.  Notice that the mouse cursor will change when you hover over these areas.  The following screen 
shot illustrates changing the vertical space between the chart area and watch list area in the Home page: 

Resize Panels 
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2.3.5 Adding New Panel Tabs 

New panel tabs can be added to each panel area in the active page.  Simply click on the New Tab button 
to the right of the existing tabs.  The follow screen shots show the sequence to add a new chart to the 
main panel of the Home page.  In this example, three charts are stacked on top of each other with the 
active chart showing with the highlighted tab (in white). 

Add New Panel Tab 

 
New Chart Tab Dialog 

 
New Tab Added 

 

2.3.6 Creating a Custom Layout 

MotiveWave™ includes a number of built-in page layouts which are available when you create or edit 
the page.  You can organize the panels in the page however you like by clicking and dragging the tabs 
around.  As you drag the tab, you will see a highlighted blue area where the panel will be created when 
you release the mouse button.  This feature provides you the flexibility to create any layout with any 
number of panels.  The following screen shot illustrates moving the chart tab that we created in the 
previous section (INTC symbol) and creating a new panel area by horizontally dividing the existing panel 
into two. 
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Custom Layout Step 1 

 
Custom Layout Step 2 

 

2.4 Changing the Look and Feel 

MotiveWave™ provides several options for changing the look and feel of the window decorations 
(Microsoft Windows only), docking framework, table colors and chart colors.  Use the Preferences dialog 
to change these attributes (as well as many others).  This dialog can be opened by pressing the 
Preferences Button at bottom right of the console window or by choosing Configure -> Preferences from 
the top menu bar. 
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Preferences Button 

 

If you would like to modify the preferences for the docking framework, click on the General tab then on 
the Dock sub tab.  Several options are available from this panel (see below): 

Dock Preferences 

 

The Themes tab provides several options for changing the look and feel of the window decorations 
(Windows platform only) as well as the colors for the chart, tables and buy/sell boxes.  Custom Chart 
and Bar themes can be defined under the corresponding tabs of this section: 

Themes 

 

The following screen shot shows an example of some theme changes:  



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 23 of 190 

 

Theme Sample 

 

2.5 Instruments 

Stocks, FOREX pairs, futures contracts, indices etc are generically referred to as Instruments in 
MotiveWave™.  The available instruments will depend on the broker or data service that you chose for 
the workspace.  When you initially create a workspace in MotiveWave™ a default set of instruments will 
be populated in the local database.  Additional instruments can be added by searching for them.   

All instruments can be centrally managed from the Manage Instruments dialog available from the 
Console (Configure -> Manage Instruments from the top menu bar). 

Manage Instruments 

 

The Manage Instruments dialog displays all of the instruments that are defined in the local database.  
You can filter the list by typing in a symbol (or partial symbol) or choosing a specific instrument type or 
exchange. 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 24 of 190 

 

Manage Instruments Dialog 

 

Additional instruments can be added to the local database by either clicking the Search or Define 
buttons (Note: the Define and Import buttons are not available for all brokers/data services). 

The Search button will utilize the broker/data service’s search capabilities to discover new instruments 
that you can add to the local database.   

2.5.1 Importing Instruments 

For convenience, the Import button will allow you to import a set of instruments from a CSV (comma 
separated values) file.  This file can be created using a spreadsheet (such as Microsoft Excel) and saving 
it as a CSV file.  For details on the format of the file, see: 
http://www.motivewave.com/data/import_instruments.htm 

Import Instruments Dialog 

 

2.5.2 Trading Hours 

Trading hours define the days and time of day that an Instrument is traded.  For most instruments the 
trading hours may be assigned automatically by MotiveWave™.  When you create your workspace, 
MotiveWave™ will create a default set of Trading Hours.  You can create your own trading hours and 

http://www.motivewave.com/data/import_instruments.htm
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override the instrument settings.  Trading hours can be created/modified from the Preferences dialog 
(Configure -> Preferences from the Console menu bar, click on General then on Trading Hours). 

Trading Hour Preferences 

 

The Trading Hours dialog will appear when you click the add button (green ‘+’) above.  If an exchange is 
chosen, then the hours defined in this dialog will be used as the default trading hours for instruments on 
that exchange. 
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Trading Hours Dialog 

 

The Trading Hours for an instrument can be assigned from the Advanced tab of the Instrument dialog.  
This dialog can be accessed from the Manage Instruments dialog (Configure -> Manage Instruments 
from the Console menu bar) or from the Context menu of a chart (right click on a chart and choose Edit 
Instrument). 

Edit Instrument 
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Edit Instrument – Trading Hours 

 

2.6 Watch Lists 

Watch Lists provide a convenient way to organize a related set of instruments together in one location.  
MotiveWave™ will create a default set of Watch Lists when you first create your workspace.   

There are two ways to view a Watch List: 

1. Table View – In this tabular view, each row displays an instrument.  The table view will have a 
default set of columns, but these can be configured by the user to show or hide any of the 
available instrument values.  Optionally, you can sort this table view by any of the columns in 
ascending or descending order. 

2. Buy/Sell View – This view shows a Buy/Sell box for each instrument.  The current Best Bid and 
Best Ask values are shown along with the last price, last time, daily high/low and spread.  Market 
orders can be placed directly by clicking on the Buy or Sell areas. 

The following screen shot shows the default set of watch lists displayed on the Home page.   

Default Watch Lists 

 

2.6.1 Watch List Tool Bar 

Several features are available from the tool bar in the top right area of the watch list panel.  These 
buttons are as follows: 
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1. Link With Chart – If this button is on (shaded background), clicking on a row in the watch list will 
set the instrument for the active chart on this page. 

2. Table/Buy Sell View – Toggles the view of the watch list between the table view and the Buy/Sell 
boxes view 

3. Sorted / Unsorted – Toggles the sort mode for the watch list.  If unsorted, you can manually 
arrange the order of the rows in the table by clicking/dragging them.  If in “sorted” mode, you 
can click on the column headers to sort the table in ascending/descending order 

4. Add Instrument – Use this to add an instrument to the watch list that already exists in the local 
database. 

5. Search And Add Instrument – Launches the search dialog to search for an instrument and add it 
to the watch list. 

6. Import Instruments – Click this to import a set of instruments from a CSV file (not available on all 
workspaces) 

7. Open Watch List – Click this button to open a watch list in another panel  
8. Edit Watch List – Edits the watch lists properties 
9. Create Watch List – Use this to create a new watch list 
10. Open in Window – Opens this watch list in a separate window 
11. Maximize – Maximizes the watch list panel to use all of the available space on the page 

The following screen shot shows these buttons in the tool bar: 

Watch List Tool Bar 

 

2.6.2 Sorting Options 

The table view of the watch list can be either sorted or unsorted.  This mode can be toggled by clicking 
the sort button on the tool bar (see previous section).   

2.6.2.1 Sorted View 

In the sorted view, you can click on the column headers to sort the watch list.  The first click will sort by 
that column in ascending order.  Clicking again will sort in descending order: 
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Sorted Watch List 

 

2.6.2.2 Unsorted View 

In the unsorted view, you can arrange the instruments in the list by clicking and dragging them to the 
desired location.  Alternatively, right click on a row and choose Move Up / Move Down to adjust their 
locations. 

Unsorted Watch List 

 

2.6.3 Buy/Sell Boxes 

A Buy/Sell box shows the current Best Bid and Best Ask prices for an instrument and makes it easy to 
quickly place a market order to buy or sell the instrument.  The following diagram shows the elements of 
a Buy/Sell box: 
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Buy/Sell Box 

 

The colors of the box will change as the prices change.  If the price goes up the label will flash blue (or 
green depending on preferences).  If the price goes down, the label will flash red. 

The Buy/Sell view of the watch list will display the instruments in unsorted mode (see section above).  
You can easily arrange the order of these boxes buy clicking and dragging the title bar.  Click on the ‘X’ 
button in the top right corner to remove a box from the watch list. 

Sorting Buy/Sell Boxes 

 

You can modify the preferences for the Buy/Sell boxes from the Preferences dialog (Configure -> 
Preferences from the Console menu bar). 
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2.6.4 Create Watch List 

Click on the New Watch List button on the Watch List tool bar or select File -> New -> New Watch List 
from the Console menu bar to create a new watch list. 

On the first page of the New Watch List wizard, you will be asked for the name of the Watch List.  This 
name will be displayed on the panel tab. 

New Watch List – Page 1 

 

On the next page of the wizard, you will be asked to specify the columns.  If you would like to add one or 
more columns to the list, select them from the Available Columns list (hint: use the Ctrl key or Cmd key 
on the Mac to select multiple rows) and press the ‘>’ button to move them to the Selected Columns list.  
If you would like to remove one or more columns, select them from the Selected Columns list and press 
the ‘<’ button. 
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New Watch List – Select Columns 

 

The last step is to choose the set of instruments that will be displayed in the Watch List. Click on the Add 

Instrument button to add an existing instrument to the Watch List.  Click on the Search  to search 
for an instrument and add it to the Watch List. 

New Watch List – Choose Instruments 

 

2.6.5 Edit Watch List 

Click on the Edit Watch List  button on the Watch List tool bar to open the Edit Watch List dialog.  
From this dialog you can change the name, available columns or the instruments. 
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Edit Watch List - Configuration 

 
Edit Watch List - Instruments 

 

For convenience, column can be modified directly from the Watch List.  Click and drag a column header 
to change the order.  On the right hand side of the column header, there is a button that can be used to 
show or hide columns. 

Edit Watch List Columns 
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2.7 Quote Sheets 

Note: this feature is not available in Analyst and Trade version of MotiveWave™ 

A Quote Sheet is a Watch List that can be divided into sub groups.  One way to add a Quote Sheet to the 
Console is to choose the Quote Sheet option from the Add Tab button: 

Add Quote Sheet 

 

On the first page of the New Quote Sheet Wizard, you will be asked to enter a name for the Quote 
Sheet.  Similar to the Watch List, this will be displayed in the tab of the Quote Sheet Panel. 

New Quote Sheet Wizard 

 

Choosing the columns for the Quote Sheet is the same as you would for a Watch List.  Select the 
column(s) you would like to add from the Available Columns list and use the ‘>’ button to add them to 
the Selected Columns list. 
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New Quote Sheet – Select Columns 

 

Quote Sheets organize instruments into groups.  Click on the New Group button to add one or more 
groups to the Quote Sheet.  You can add instruments to each group by selecting the group from the 
Group drop down and then using the Add Instrument/Search Instrument buttons (see below). 

New Quote Sheet – Add Groups/Instruments 

 

The following screen shot shows a sample Quote Sheet.  Noticed that there are groups in the Quote 
Sheet table that divide the instruments into different categories.  Optionally each group can have 
different colors for the dividers. 
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Sample Quote Sheet 

 

2.8 Backup/Restore 

Note: This feature is not available in the trial versions of MotiveWave™ 

The Backup/Restore feature enables you to export settings, analyses, instruments, watch lists, scans and 
open windows/positions to a single backup file.  This backup file can be archived to be restored later in 
case something happens to your computer.  Alternatively, you can use this feature to transfer your 
workspace to another computer. 

2.8.1 Creating a Backup 

Choose File -> Backup from the Console menu bar to create a backup file.  When you choose this option, 
you will see the Backup Workspace dialog. 

Create a Backup 
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Backup Dialog 

 

The backup dialog enables you to choose what is included in the backup file:  

1. Include Console – This will include the console layout (pages etc). 
2. Include Open Windows – This will preserve the open charts, DOM windows etc and their 

locations on the screen. 
3. Include Preferences – These are the preferences that you have modified in the Preferences 

dialog. 
4. Include Watch Lists – These are the watch lists and quote sheets. 
5. Include Scans – These are the scan criteria. 

When you click the Create button, a backup file will be created on your computer desktop.  This backup 
file will be named <Workspace Name> <Date>.mwb (where <Workspace Name> is the name of your 
workspace and <Date> is the current date/time).  If you would like to change the name and location, 
click on the Browse button.  

You can store this file in a safe place (such as Drop Box or Google Drive) or move it to another computer 
to restore it into an existing workspace. 

2.8.2 Restore From Backup 

Choose File -> Restore from the Console menu bar to restore from a previously created backup. 

Restore From Backup 
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Restore Dialog 

 

Click on the Browse button and locate the backup file that you created previously.  The options available 
for restore are as follows: 

1. Restore Console – Restores console layout and pages from the backup file. 
2. Restore Windows – Restores the open windows and locations 
3. Restore Preferences – These are the settings from the Preferences dialog. 
4. Restore Watch Lists – Watch Lists and Quote Sheets 
5. Restore Scans – Scan criteria saved from the backup 
6. Delete Existing Analyses – If you check this option, all of the existing analyses in the workspace 

will be deleted before importing the analyses from the backup. 

Click the Restore button to begin the restore process.  You will see a progress indicator that reports the 
status of the restore.  Depending on your computer and the size of the backup, this could take up to a 
minute or two to complete. 

2.8.2.1 Restoring to a Different Workspace Service 

In the typical case, the workspace service (ie broker or data service) will match the service from the 
backup.  You can restore from a backup that was created with a different service, but you may 
encounter some issues.  Each service has a different naming symbology for the instruments that they 
support and the target service may not support all of the instruments that are in the backup. 

MotiveWave™ will attempt to map the symbols from the backup service to the target service.  However, 
you may find that some analyses are missing in the new workspace if MotiveWave™ could not find a 
mapping. 

2.9 Repository 

Note: This feature is not available in the trial editions of MotiveWave™ 

MotiveWave™ maintains a local database for each workspace.  This database contains the following 
information: 

1. Instruments/Exchanges/Trading Hours 
2. Preferences 
3. Watch Lists/Quote Sheets 
4. Historical News 
5. Analysis 
6. Alerts  
7. Chart Templates 
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8. Scan Criteria 
9. Strategy Analysis 
10. Historical Trades 
11. Historical Data – Historical data is stored in 1, 5, 30 and daily bars.  This is used to reduce load on 

the servers and is also available in Offline mode. 

Optionally, data that is normally stored in the local database can be stored in the file system.  This can 
be very useful if you want to synchronize this data (using Google Drive or Drop Box) with other 
computers or use as an alternative way to create backups. 

Choose Configure -> Repository from the Console menu bar to access the Repository settings. 

Repository Settings 

 
Repository Dialog 

 

Uncheck the Use Local Database option to store information in the File System instead of the database.  
You will need to choose the root directory for this information by clicking the Browse button.  If you 
would like to share this data using Google Drive or Drop Box, make sure to choose a location inside the 
shared folder. 

Optionally you can choose to store the following types of information by checking the boxes below:  

1. Include Preferences – this is the settings in the Preferences dialog and other configured settings. 
2. Include Watch Lists – watch lists and quote sheets 
3. Include Chart Templates – any study templates that you have setup in your system 
4. Include Windows & Layouts – open window information and locations as well as the Console 

layout 
5. Include Scans – scan criteria 
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6. Include Global Alerts – this applies to price alerts. 

2.9.1 Sharing using Google Drive or Drop Box 

Storing data in the File System provides the flexibility to share this information with other computers 
using utilities such as Google Drive or Drop Box.  Note: this feature is not limited to these two services.  
Any cloud based service that interacts with your local file system should work just as well.  

For more information on these services, see their websites: 

1. https://www.dropbox.com/ 
2. https://drive.google.com/ 

Note: some issues have been found with Google Drive.  These issues are related to the behavior of 
Google Drive when sharing files.   For more information see: http://www.techrepublic.com/blog/google-
in-the-enterprise/steering-around-the-potholes-with-google-drive/ 

2.9.2 Folder Structure 

If you look at the root folder for the repository you will see two folders: 

1. analysis – contains analysis files.  This directory contains several sub folders that organize 
analysis by instrument type and instrument symbol. 

2. config – contains configuration files 

The following diagram shows an example repository structure for an FXCM workspace.  
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Repository Folder Structure 

 

2.9.3 Analysis Sources 

Analysis sources provide a way to share specific analyses or to access analyses from other MotiveWave™ 
users.  Analysis sources are defined by a folder that exists in your local file system.  You would need to 
use a service such as Google Drive or Drop Box to perform the sharing and synchronization.  

Analysis sources are defined in the Repository Dialog (Configure -> Repository from the console menu 
bar) 
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Repository Dialog – Analysis Sources 

 

Click on the Add button to define an analysis source.  You can have multiple analysis sources.  The 
Override Repository option is important if there are naming conflicts between your local repository and 
the analysis sources.   

For example if you created an analysis called “Wave 3 Intraday” for the EUR/USD pair and one of the 
analysis sources also has an analysis called “Wave 3 Intraday” for EUR/USD, MotiveWave™ will need to 
determine which one to display.  If Override Repository is checked, it will display the one from the 
analysis source (instead of the local repository). 

The following dialog will appear when you click the Add button.  Each analysis source will require a 
name.  This name can be anything you like, but should reflect the source of the analyses.  In the example 
below, we chose the name “Trading Analysis” (this is one of our partners).   Choose a directory (folder) 
for the source by clicking on the Browse button.  (Note: this will be a folder that is synchronized using 
Google Drive/Drop Box). 

The Read Only attribute indicates if you are going to be modifying the analyses or just viewing them.  
Uncheck this option if you are intending to publish analyses to this source. 

Add Analysis Source Dialog 

 

2.9.3.1 Publishing Analyses 

If you are planning to share your analyses with other users, then you would create an analysis source 
and uncheck the Read Only attribute.  Analyses that exist in your repository are not automatically 
shared; you will need to explicitly publish each analysis to this new source. 
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If you would like to publish an analysis to an analysis source, choose File -> Save To -> <Analysis Source 
Name> (where <Analysis Source Name> is the name you chose in the Add Analysis Source Dialog) from 
the chart menu bar (Note: it is File -> Chart -> Save To -> <Analysis Source Name> from the Console). 

This action will save this analysis (make a copy) to a sub folder in the analysis source folder that you 
defined earlier. 

The file synchronization software that you setup (ie Drop Box etc) will take care of synchronizing that file 
with the folders of all your users. 

In the following example, we have created an analysis source called My Group.  The Read Only attribute 
has been unchecked to tell MotiveWave™ that it can publish analyses to this location.  This analysis 
source will now be available in the Save To menu (see below).  

Setup for My Group 

 
Publishing to My Group 

 

2.10 Email Configuration 

MotiveWave™ may be configured to send out email messages as part of alerts or signals generated by 
studies.  You will need to configure the SMTP (Simple Mail Transfer Protocol) settings in the Preferences 
dialog to enable this feature.  These settings will be found under the Email tab.  Choose Configure -> 
Preferences from the Console menu bar to display the Preferences dialog. 
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Email Preferences Dialog 

 

If you are using a corporate email address, you will need to contact your network administrator to get 
the specific SMTP settings. 

Settings for public email addresses can be found online, just do a web search.  Here are some useful links 
for some common email providers: 

2.10.1 Gmail  

Gmail settings can be found here: 
http://email.about.com/od/accessinggmail/f/Gmail_SMTP_Settings.htm 

For some user accounts you may need to create an application specific password in order for this to 
work.  For more information see: https://support.google.com/mail/answer/1173270?hl=en 

2.10.2 Yahoo Mail 

Yahoo mail settings can be found here: 
http://email.about.com/od/accessingyahoomail/f/Yahoo_Mail_SMTP_Settings.htm 

Similar to Gmail you may need to setup an application specific password if you have to bypass the 
second sign-in verification: https://help.yahoo.com/kb/yahoo-account/SLN5013.html?impressions=true 

2.10.3 Windows Live / Hotmail 

The following link explains the Hotmail SMTP settings: 
http://email.about.com/od/accessinghotmail/f/Windows_Live_Hotmail_SMTP_Settings.htm 
 
There is also a two-step verification process for Hotmail as well.  For more information see: 
http://windows.microsoft.com/en-ca/windows/two-step-verification-faq 

http://email.about.com/od/accessinggmail/f/Gmail_SMTP_Settings.htm
https://support.google.com/mail/answer/1173270?hl=en
http://email.about.com/od/accessingyahoomail/f/Yahoo_Mail_SMTP_Settings.htm
https://help.yahoo.com/kb/yahoo-account/SLN5013.html?impressions=true
http://email.about.com/od/accessinghotmail/f/Windows_Live_Hotmail_SMTP_Settings.htm
http://windows.microsoft.com/en-ca/windows/two-step-verification-faq
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3 Charts 

MotiveWave™ has perhaps some of the most advanced charting capabilities of any charting application 
available.  In this section we will be exploring some of the basics of working with charts in 
MotiveWave™. 

You can work with charts within the Console window or you can open separate chart windows to w ork 
with charts independently.  The simplest way to open a chart window is to press the Open Chart 
Window button from the top right section of a chart panel.  Alternatively, choose File -> New -> New 
Chart Window from the top menu bar. 

Open Chart Window 

 

This action will open a chart window similar to the one in the screen shot below.  Regardless of whether 
you choose to work with charts in the console or separate chart windows, the features described in this 
section are the same. 

Chart Window 

 

3.1 Settings 

3.1.1 Default Chart Settings and Options 

Default chart settings can be set from the Preferences Dialog (Configure -> Preferences from the Console 
menu bar).  You will find the settings for charts in the tabs underneath the Chart tab. 
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Global Chart Settings 

 

The following are options that are available from the Chart Settings tab:  

1. Default Tool – This is the default tool to use on a chart.   
2. Revert to Default Tool – When completing an action with the selected tool, the chart will 

automatically switch back to the default tool (see above) 
3. Bar Type – The default type of bar to display when opening a chart 
4. Bar Scheme – Determines the color scheme for the bars.  Normal displays bar color based on if the 

close is higher/lower than the open value.  Available Bar Schemes include: 
a. Normal – Displays a different color if the bar closes higher than open verses lower than open 
b. Inside/Outside – Colors change if bar closes higher/lower than open, if the bar has a lower 

high/higher low than previous bar (inside) and if the bar has a higher high/lower low than the 
previous bar (outside) 

c. Day Of Week – Bar color changes based on the day of the week 
d. Alternate Day – Bar color alternates each day 
e. Alternate Hour – Bar Color alternates each hour 

5. Bar Size – default bar size when opening a new chart 
6. Bar Thickness – Default thickness for the bar outline (default 1 pixel) 
7. Axis Style – Style of the price and time axis 
8. Shade – draws a shaded area at time or price intervals on the 
9. Shift + Click – Object to draw when the user holds down on the Shift Key and clicks the left mouse 

button on the chart. 
10. Ctrl + Click – Object to draw when the user holds down on the Ctrl Key and clicks the left mouse 

button on the chart. 
11. Shift + Alt + Click – Object to draw when the user holds down on the Ctrl and Alt Keys and clicks the 

left mouse button on the chart. 
12. Line Method – Calculation method for calculating the lines on a wedge (Time/Price or Angle)  
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13. Fill Area – If true, the area of a wedge will be filled 
14. Fill Alpha – Alpha value for the fill color 
15. Max Linear Bars – Maximum number of linear bars to load when opening a chart 
16. Max Non Linear Bars – Maximum number of non-linear bars (ie Range, Renko etc) to load when 

opening a chart 
17. Minimum Bars – Minimum number of bars to load when opening a chart. 
18. Bar Width (pixels) – Default spacing for the price bars 
19. Price Axis Spacing – Default spacing between the numbers that are displayed on the price axis  
20. Time Axis Spacing – Default spacing between the labels that are displayed on the time axis  
21. Top Inset (pixels) – Default spacing to add to the top of the price plot when auto scale is enabled 
22. Bottom Inset (pixels) - Default spacing to add to the bottom of the price plot when auto scale is 

enabled 
23. Study Height (pixels) – Default height for study plots 
24. Study Divider Size – Size of the resizable divider between the plots on the chart. 
25. Study Layout – Layout preference for the study labels displayed in the legend area (horizontal or 

vertical) 
26. Time Zone – Default time zone for the chart. 
27. Calendar Days – If enabled, space will be preserved for non-trading days when displaying daily bars 

(normally this space is removed) 

Additional chart options can be found under the Options tab of the Chart section in the Preferences 
dialog. 

Global Chart Options 

 
1. Show Extended Data – If true, after hours data is show by default when opening a chart 
2. Show Instrument Title – Displays the title of the instrument in the top left corner of the chart 
3. Snap Open/Close – If this is enable the mouse tools will automatically snap to open and closing 

points on the price bars 
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4. Show Components Panel – Displays the components panel by default when opening a new chart. 
5. Show Trade Panel – Displays the Trade panel by default when opening a new chart 
6. Show DOM Panel – Displays the DOM (Depth of Market) panel by default when opening a new chart 
7. Show Grid – Displays horizontal and vertical lines on the chart 
8. Show Major Times – Show vertical dashed lines for major time on the chart  
9. Show Chart Buttons – Enables the display buttons on the chart for adjusting the vertical space and 

bar width.  This also applies to the remove study button on study plots. 
10. Show Exchange – Toggles the display of the exchange as part of the title on the chart 
11. Show Cross Hair – Toggles the default display of the cross hair feature for the mouse cursor 
12. Global Cross Hair – If enabled, the cross hair (where enabled) will be updated across multiple charts 

that display the same instrument 
13. Double Cross Hair – Displays two vertical lines encompassing the bar where the cursor is currently 

(instead of a single vertical line) 
14. Solid Cross Hair – Displays a solid line instead of a dashed line for the cross hair 
15. Auto Scale – Default scale setting when opening a new chart 
16. Auto Scale Price Only – If enabled, only the price action will be included in the auto scaling of the 

chart (components are excluded) 
17. Lock Scroll – Default lock scroll state (see Lock Scroll feature) 
18. Lock Studies – Default Lock Studies state (see Lock Studies feature) 
19. Show Info on Select – Turns on the Show Info feature when selecting a component 
20. Show Info – Enables the show info feature when creating a new component 
21. Show Range Outline – Turns on the range outline on the latest bar for Range/Renko bars 
22. Show Middle Line – Turns on the display of the middle line for channel components 
23. Show Menu Bar – Turns on the display of the menu bar for windows 
24. Show Tool Bar – Turns on the display of the tool bar for windows 
25. Show Status Bar – Turns on the display of the status bar at the bottom of the windows 
26. Confirm on Close – If enabled will display a warning message when closing a chart window 
27. Link Minimize/Restore – If enabled, for linked chart windows all windows in the group will be 

minimized when one of them is minimized.  Likewise when one of them is restored, all windows in 
the group will be restored 

28. Expand Status Bar Link – Expanded mode for the color link control in the status bar 
29. Show Bar Size Selector – Toggles the default display of the Bar Size Selector on charts 
30. Show Bird’s Eye View – Toggles the default display of the Bird’s Eye View when opening a chart 
31. Show Bird’s Eye Lines – Display of the vertical lines on the Bird’s Eye plot 
32. Resolve Trend Lines – If enabled, MotiveWave™ will attempt to load enough data to properly display 

all trend lines on a chart.  By default it will estimate where the starting point of a trend line is based 
on the available data.  This option will force the loading of data all the way back to the beginning of 
trend lines to improve the accuracy of the plot.  Warning: this option can cause a lot of data to be 
loaded from your broker or data service.  It is recommended that you leave this option of and turn it 
on where desired from the Chart Settings dialog (see next section). 

33. Group Studies – If enabled, study plots will be grouped together at the bottom of the chart in a 
stacked panel. 

34. Show Study Labels – Enables the display of study labels in the legend 
35. Study Bar Updates – Toggles the live updating of studies from level 1 data verses calculating the 

most recent study values on the close of a bar. 
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36. Show Values in Legend – If enabled, current study values will be displayed next to the study label in 
the study legend 

37. Simple Study Title – Simplified display of the title in the legend area 
38. Overlay Volume – Displays the volume information as an overlay on the chart instead of a separate 

plot. 
39. Hover Popup – Enables the display of an information popup when placing the cursor over an object 

on the chart 
40. Draw Candle Outline – Draws the outline of the candle rectangle. 

3.1.2 Chart Specific Settings 

Chart settings that apply to the selected chart only can be accessed by right clicking on the chart and 
choosing Chart Settings (you can also double click on the chart).  The settings configured here can be 
saved as default settings by clicking on the Save Defaults button.  Descriptions of items below can be 
found in the preceding sections. 

Chart Settings Dialog 

 

3.2 Price Indicators 

Price indicators display current price, high low (etc) on the price axis of a chart.  By default, 
MotiveWave™ will display (where available) the Last Price, Best Bid, Best Ask, Daily High and Daily Low.  
Other indicators may be (optionally) displayed in the vertical axis from overlays such as a Moving 
Average.  If you would like to show a vertical line that moves with the indicator just double click on it 
(this will toggle the display of the line). 
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Price Indicators 

 

You may change the price indicators that are displayed from the Preferences dialog.  Click on Chart, then 
on Indicators 

Price Indicator Settings 

 

3.3 Chart Spacing 

There are several options for adjusting the horizontal and vertical spacing on the chart.  The simplest 
way is to use the mouse to drag either the time axis (horizontal spacing) or the price axis (vertical 
spacing).  Buttons are available on the chart to make fine adjustments to the spacing.  Note: in order to 
adjust the vertical spacing, you need to click and drag the space between the price labels and the chart 
area (see below) 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 51 of 190 

 

Chart Spacing 

 

3.4 Bar Sizes 

Bar sizes are useful for changing the resolution of a chart based on time, price or volume movements.  
MotiveWave™ supports several different types of bars: 

1. Linear – time interval based bars (such as 1 minute, 15 minute, 1 day, 2 week etc) 
2. Range – bars are based on price movements of a specific price range 
3. Renko/Hybrid Renko – these are special price range based bars 
4. Tick – these bars are based on a specific number of price ticks (or trades) 
5. Volume – each of these bars will have a fixed trading volume 
6. Point & Figure 

Note: Only linear bars are supported in the Analyst and Trade Editions 

There are several ways to change the bar size and type.  Perhaps the most convenient way is to use the 
Bar Size Selector at the bottom of the chart.  Alternatively, you can use the bar size drop down from the 
tool bar or right click on the chart and select the bar size from the context menu. 
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Select Bar Size 

 

3.4.1 Custom Bar Sizes 

MotiveWave™ comes with a default set of bar sizes, but you can create your own bar sizes from the 
Preferences Dialog (Configure -> Preferences from the Console menu bar).  You can create second based 
bars provided you have access to historical tick data.   

Custom Bar Sizes 

 

3.4.2 Bar Size Selector 

The Bar Size Selector is a convenient way access common bar sizes by simply clicking on one of the tabs 
at the bottom of the chart.  The Bar Size Selector is visible by default on all charts.  If you would like to 
hide this, choose View -> Display -> Bar Size Selector from the top menu bar to toggle its visibility.  (Note: 
the default behavior can modified in the Preferences Dialog, click on Chart the on Options, see Show Bar 
Size Selector option). 
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You can configure the tabs available in the Bar Size Selector by right clicking on one of the tabs and 
choosing Configure.  You can put any type of bar size in the selector.  For example you could have 
Range(3) or Constant Volume(500). 

Configure Bar Size Selector 

 

 

The Bar Size Selector also has some buttons on the right hand side.  These can be convenient for the 
following (in order from left to right): 

1. Toggle Birds Eye View – Toggles the display of the Birds Eye View 
2. Edit the Bar Size Settings – Shows the Bar Settings panel of the Chart Settings Dialog 
3. Display Time Frame – Choose a specific time frame to display on the chart (ie 2 week, 1 day etc)  
4. Go To Date – Go to a specific date in history 
5. Show Latest Data – Show the latest bars 
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Bar Size Selector Buttons 

 

3.5 Importing Data 

Note: This feature is not available in Analyst or Trade Editions 

Historical data may be imported into MotiveWave™ by choosing File -> Import Data from the top menu 
bar (File -> Chart -> Import Data from the Console menu bar).  Two types of data formats are supported:  

1. CSV – Comma Separated Values.  This is a very common format for many historical data services.  
The format of the data file will be automatically detected when specifying files of this type. 

2. MetaStock™ Database – MetaStock™ Database files containing 1 or more instruments may be 
imported into MotiveWave’s historical database. 

This dialog has the following elements: 

1. Data Files – Specify one or more data files by clicking on the Add button to left of the Data Files 
list. 

2. Time Zone – Choose the time zone for the input file.  This is important for resolving the 
data/time values for each historical price bar in the input file. 

3. Exchange – Optionally Choose the Exchange for the instrument(s) in the input file(s). 
4. Trading Hours – If a value is chosen for Trading Hours, it will be assigned to the instrument when 

it is created from this dialog. 
5. Adjust for Stock Splits – If the file does not contain split adjusted values, this will detect and 

adjust historical prices for splits. 
6. Automatically Create Instrument (Do Not Prompt) – If the instrument does not already exist in 

the local database, it will be automatically created if this is checked. 
7. Regular Trading Hours (RTH) Data (If Not Indicated) – Specifies that this is data for the regular 

trading session vs the extended session 
8. Replace Existing Data – Replaces data that is already in the local historical database. 
9. Monitor Input File For Changes – If checked, MotiveWave™ will monitor the timestamp on the 

input file to see if it changes in the future.  If it does change, the new data will be automatically 
loaded into MotiveWave™ when a chart is loaded. 
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Import Data Dialog 

 

3.6 Exporting Data 

Note: This feature is not available in Analyst or Trade Editions 

Historical data may be exported from MotiveWave™ in several different formats.  Choose File -> Export 
Data from the top menu bar (File -> Chart -> Export Data from the Console menu bar).  This dialog has 
the following elements: 

1. Symbol – Choose the instrument that you would like to export.  By default this is the instrument 
from the chart where the dialog was launched. 

2. Bar Size – Choose the Bar Size for the historical data 
3. Bar Count – Number of Bars to Export.  Choose All Available to export all available data in the 

historical database 
4. Regular Trading Hours (RTH) Data – Check this to only include bars that are part of the regular 

trading session 
5. Data File – Click on the Browse button to the right to choose the data file where the data will be 

saved. 
6. Format – Choose the Export Format 

a. CSV – yyyyMMdd HHmmss,O,H,L,C,V 
b. CSV – dd/MM/yyyy HH:mm:ss,O,H,L,C,V 
c. Ninja Trader – Start Of Bar Time 
d. Ninja Trader – End Of Bar Time 
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Export Data Dialog 

 

3.7 Bird’s Eye View 

The Birds Eye View provides a convenient way to view the larger picture of the available historical data.  
Choose View -> Display -> Bird’s Eye View from the top menu bar to toggle the display of this feature. 

Display Bird’s Eye View 

 

The Bird’s Eye View is displayed at the bottom of the chart.  The highlighted area (transparent yellow 
area) illustrates the data that is currently visible in the chart.  You can click and drag this area to the 
left/right to move the visible area.   The width of the highlighted area depends on the bar width for the 
chart.  If you would like to change the width, click and drag the time axis.  

Bird’s Eye View 
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3.8 Cursor Data 

Cursor Data refers to the data points and their values at the current position of the mouse cursor.  There 
are several different ways to view cursor data.   

3.8.1 Cursor Data Window 

The cursor data window is a separate window that displays data at the current mouse location.  This 
window works across all charts.  This window may be opened by choosing View -> Display -> Cursor Data 
Window from the top menu bar.  For convenience this window is always displayed on top of other 
windows. 

Open Cursor Data Window 

 
Cursor Data Window 
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3.8.2 Cursor Data Panel 

The Cursor Data Panel is essentially the same as the Cursor Data Window except that it is a panel inside 
of the chart.  This panel only works for the enclosing chart.  To open this panel, choose View -> Cursor 
Data from the top menu bar. 

Open Cursor Data Panel 

 
Cursor Data Panel 

 

3.8.3 Bar Status 

Data on the selected price bar can be found in the status bar at the bottom of the window.  This reflects 
the price bar at the position of the mouse cursor. 
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Bar Status 

 

3.8.4 Hover Popup 

A popup will be displayed with information about the price bar if you place the mouse cursor over a 
price bar and leave it there for about 2 seconds. 

Price Bar Hover Popup 

 

3.8.5 Cross Hair 

The cross hair feature draws thin horizontal and vertical lines at the current mouse cursor location to 
indicate the vertical axis and time axis values. 
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Cross Hair 

 

There are several configuration options for the cross hair.  These can be found under the Chart -> 
Options tab of the Preferences dialog (Configure -> Preferences from the Console menu bar). 

Cross Hair Preferences 

 

3.8.5.1 Global Cross Hair 

The Global Cross Hair provides a convenient way to locate the mouse cursor position between several 
different charts that are displaying the same instrument.  This option can be enabled in the Preferences 
dialog (see previous section).   In the following screen shot you will notice that the current location of 
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the mouse cursor in one chart adjusts the cross hair location in the other charts that show the same 
instrument. 

Global Cross Hair 

 

3.9 Time & Sales 

Note: This feature is not available in Analyst or Trade Editions 

The Time & Sales panel shows historical ticks for the selected instrument.  The data and columns 
available in this panel will depend on the broker or data service that you have chosen.  The following 
example shows the Time & Sales panel for MSFT on the Tradier Brokerage workspace:  

Time & Sales Panel 
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For convenience, a button is available on the tool bar to toggle the display of this panel.  Alternatively 
choose View -> Display -> Time & Sales Panel from the top menu bar. 

3.10 Depth Of Market (DOM) Panel 

Note: This feature is not available in Analyst or Trade Editions 

The Depth Of Market (DOM) panel shows a tabular view of the current bid and ask sizes.  Choose View -> 
Display -> DOM Panel from the top menu bar to show or hide this panel on a chart.  For convenience a 
toggle button is also available on the tool bar.  For details on how to use the DOM panel see Depth Of 
Market section. 

Depth Of Market Panel 

 

3.11 Chart Labels 

Chart labels display information on the Price Plot of the chart.  These labels can appear in any of the 4 
corners.  The following example shows some chart labels: 
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Chart Labels 

 

You can configure the labels displayed on a chart from the Chart Settings Dialog (double click on the 
chart).  You will find the labels under the Labels tab: 

Chart Label Settings 

 

The following shows the properties for a chart label (click the edit button next to the label, see above). 
From there you can choose which corner to display the label and adjust the color, font etc.  The order in 
which the labels are displayed is determined using the up/down arrow buttons in the Chart Settings 
Dialog (see above). 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 64 of 190 

 

Chart Label Properties 

 

3.12 News 

If supported by your Broker/Data Service, news articles specific to the instrument can be displayed on 
the chart by showing the News Headlines panel.  Choose View -> Display -> News Headlines from the top 
menu bar. 

News Headlines Panel 

 

If you click on a headline in the news headlines panel, it will display the news article in the internal news 
viewer by default.  If you right click on the headline, you can optionally display the news article in your 
web browser. 
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Show News Article 

 
The following screen shot shows an example of displaying a news article in the News Viewer: 

News Viewer 

 

3.13 Watermark 

The Watermark feature in MotiveWave™ enables you to display a semi-transparent label with the 
instrument’s symbol and/or description.  You can also choose the location and font of this label.  The 
watermark can be configured from the Chart Settings dialog, see Watermark tab. 
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Watermark Settings 

 

The following screen shot shows the watermark description for Microsoft: 

 

3.14 Scaling 

Several different scaling options are available for scaling the price/time range of the price plot.  By 
default the chart price range is automatically scaled from the visible data and components (Auto Scale).  
The following are the available scaling options: 

1. Auto Scale – Price range is adjusted according to visible data and visible components (optionally, 
only the data range can be considered).  This option will lock the vertical movement of the chart. 
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2. Price Range – This option keeps the price range constant and enables you to manually move the 
graph up/down. 

3. Square – This option will set a fixed number of points per bar width.  If the bar width is expanded 
(or contracted) the price range will be updated to reflect. 

Scaling options can be found under the Scaling tab of the Chart Settings dialog. 

Scaling Options 

 

3.15 Analyses 

MotiveWave™ employs the concept of an Analysis to encapsulate the work that you have done in a 
chart to analyze price movement.  An analysis will contain the following types of information: 

1. Components – any components that you have added to the chart including: trend lines, Elliott 
Waves, Gann components, Gartley patterns, commentary etc 

2. Studies – Any studies that you have added to the chart 
3. Time/Price Guides – These are guides that you have added to the horizontal or vertical axes. 

It is important to understand that an analysis is a separate entity from a chart.  A chart is a view or an 
analysis file.  This is an important distinction and is fundamental to the underlying design of 
MotiveWave™.  While this concept may seem a little confusing at first, it has numerous advantages: 

1. View in Multiple Time Frames – A single analysis can be viewed at multiple time frames 
simultaneously.  You can have several open charts that reference the same analysis and edit 
them from each chart. 

2. Alternate Analyses – Each instrument can have any number of analyses.  The name of an analysis 
is scoped to the instrument so it does not have to be unique across symbols. 

3. Saved in Repository – You can save an analysis and load it later after the chart has been closed 
4. Share with other People – Analyses can be exported in XML format and shared with your friends.  

You can also share analyses using the Analysis Sources feature. 

The following diagram illustrates the relationship between charts and analyses.  Each instrument may 
have multiple analyses which are saved in the local database (repository).  When you open a chart, you 
are opening an analysis.  MotiveWave™ allows you to open an analysis from more than one chart at the 
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same time.  Changes made in either chart are synchronized between the two so you do not have to 
worry about overwriting you modifications. 

Charts and Analyses 

 

3.15.1 Creating a New Analysis 

The default analysis for any instrument is called the Primary Analysis.  Whenever you open a chart for 
the first time, it will open the Primary Analysis.  The net effect of this behavior is that all changes 
between the open charts for that instrument will be synchronized between them.   

If you do not want these changes to be synchronized, you can create one or more Alternate Analyses.  
There are several ways to do this; perhaps the most convenient is to use the New Analysis button on the 
tool bar. 
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New Analysis 

 

The following dialog will appear when you create a new analysis.  Enter a name for the analysis.  By 
default, analyses are named Alternate 1, Alternate 2 etc.  You can however choose any name you like for 
the analysis.  A new analysis may be empty (just price bars) or you can base an analysis on an existing 
analysis by choosing one from the Based On drop down. 

New Analysis Dialog 

 

Once you have created the new analysis, the chart will display a set of tabs at the top where the active 
tab is named with the new analysis. 

Chart with New Analysis 

 

3.15.2 Open Existing Analysis 

If you want to quickly open an analysis, just click on the small black triangle next to the open button on 
the tool bar.  Alternatively, choose File -> Open/Manage Analyses from the top menu bar (File -> Chart -
> Open/Manage Analyses from the Console menu bar). 

andrey
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Open Analysis 

 

3.15.3 Manage Analyses 

The Manage Analyses dialog allows you to open, rename, delete or create new analyses for the given 
instrument.  This dialog can be access from the menu bar: File -> Open/Manage Analyses from the top 
menu bar (File -> Chart -> Open/Manage Analyses from the Console menu bar). 

Manage Analyses Dialog 

 

3.15.4 Import/Export Analyses 

Import and export are very valuable tools for sharing your analysis with another MotiveWave™ user. 

When you export an analysis file, the file will contain all of the information related to your analysis as 
well as information about the instrument. The exported file will be in XML format and will have an 
extension of .mwml (MotiveWave Markup Language). 

Choose File -> Export Analysis from the top menu bar (File -> Chart -> Export Analysis from the Console) 
to open the Export Analysis dialog.  By default the analysis file will be saved on your computer desktop in 
the form <Symbol> – <Analysis Name>.mwml. You may change this name and location if you like. Click 
on the Save button to export the analysis to the selected file. 
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Export Analysis Dialog 

 
 

Similarly, to import an analysis file, choose File -> Import Analysis from the top menu bar (File -> Chart -> 
Import Analysis from the Console) to display the Import Analysis dialog.  Locate the analysis file, select it 
and press the Open button. If the chart you are currently using has the same instrument as the imported 
analysis file, it will be opened in another analysis tab. If the instrument does not match the chart, a 
message dialog will be displayed indicating that the import was successful and how to open the 
imported file. 

Import Analysis Dialog 

 

3.16 Components 

Many different types of components can be added to a chart as part of your analysis.  Examples of 
components include Trend Lines, Price Labels, Channels, Commentary, Elliott Waves, and Markers.  
Components can be added to a chart from the Components Panel or by using the Mouse Tools (available 
from the tool bar). 

Please Note: Components panel is not available in the Analyst or Trade Editions of MotiveWave™.  In these cases you must 
use the mouse tools available from the tool bar. 

3.16.1 Components Panel 

The Components Panel organizes the available components in MotiveWave™.   This panel is displayed on 
the left hand side of the chart area and is organized into folders.  You can hide this panel by clicking on 
the ‘X’ in the top right corner of the panel.  A toggle button is available on the right hand side of the tool 
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bar to show/hide this panel as well.  Alternatively, choose View -> Display -> Components from the top 
menu bar. 

Components Panel 

 

3.16.2 Adding a Component 

To add a component from the Components Panel, simply click and drag (using the left mouse button) 
the component onto the chart area (see below).  Alternatively, you can double click on a component, or 
right click and choose Add To -> <Graph> to add it to the center of the chart. 

 

Mouse Tools are available for some of the more common components.  In some case these tools can be 
more convenient than using the Components Panel.  These mouse tools can be found under the Tools 
dropdown on the tool bar.  You can customize the tool bar to make certain mouse tools more 
convenient to access.  Short-cut keys are also available to quickly select tools.  These keys typically take 
the form of Ctrl + Shift + <Key> (see tool menu for key combinations, Note: on Mac OS X use Cmd 
instead of Ctrl.) 
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Tools Dropdown 

 

The following example shows the usage of the Channel Tool to create a channel.  This particular tool 
requires three clicks to define the channel.  Notice that the mouse cursor will change after each click to 
visually indicate what click you are on.  Also the channel is drawn as you click the mouse. 

Channel Tool 

 

3.16.3 Selecting Components 

You can select components on a chart by simply clicking on them with the left mouse button.  When a 
component is selected, you will typically see green resize points that indicate areas that you can move to 
modify the component. 
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Select Component 

 

If you want to select multiple components, simply hold down on the Shift key while clicking on other 
components.  The first component selected will have green resize points (primary component) and the 
other components will display blue resize points (secondary components).   

Select Multiple Components 

 

Selecting multiple components can be useful if you want to move them as a group or delete them.  
Some components such as trend lines have options from the right click menu (right mouse click) that 
apply to the group.  In the following example, you can make two (or more) lines parallel by selecting 
them and choosing the “Make Lines Parallel” option from the right click menu.  (Note: lines will be 
drawn parallel to the primary component, ie the one selected first):  
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Make Lines Parallel 

 
 

3.16.4 Deleting a Component 

Deleting (removing) a component from a chart is straight forward.  Simply click on the component to 
select it and then press the ‘Delete’ key on the keyboard.   Alternatively, right click on it and choose Edit 
-> Delete. 

If you want to delete all components from a chart, choose Edit -> Delete All from the top menu bar. 

3.16.5 Component Properties 

Components may be modified from the Properties dialog and (in many cases) by using the right click 
menu that is available via right click on a component.  You can open the Properties dialog by double 
clicking on a component or right click and choose Properties. 

Accessing Component Properties 

 
The following screen shot shows the Properties dialog for the Channel component.  The options available 
in this dialog will vary depending on what component you are editing. 
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Channel Properties Dialog 

 

3.16.5.1 Formatting 

Formatting options such as color, font, line width/style, shading etc can be found under the Format tab 
of the Properties dialog (double click on the component).  For convenience several formatting options 
are available on the tool bar for changing the component format.  These buttons are context sensitive 
and will apply to the selected component (see below).  These buttons will appear inactive (greyed out) if 
no component is selected. 

Formatting Options 

 

3.16.6 Working with Trend Lines 

Trend lines are an important element of most all forms of market analysis.  Several features are built 
into MotiveWave™ to make working with trend lines easier. 

Trend Lines can be created by using the Line Tool that is available from the tools drop down.  
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Selecting the Line Tool 

 

Creating a trend line requires two left mouse clicks.  The first click defines the starting point for the line 
and the second defines the end point.  Once you have created the Trend Line, you can press the Space 
bar to switch the tool back to the default Time Drag tool. 

Creating a Trend Line 

 

When a trend line is selected it will display basic information about that trend line (such as the price 
range and time span).  You can adjust the line by moving the end points (green resize points).  These 
points will snap to key locations such as the top or bottom of price bars (hold down on the ‘Alt’ key to 
disable this feature). 
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Adjusting a Trend Line 

 

Common angles (such as horizontal, vertical, 45 degree etc) can be set by holding down on the Shift key 
while moving one of the end points.  Hold down on the Ctrl key while moving one of the end points to 
maintain the current slope (angle) of the trend line. 

Locking to Common Angles 

 

Detailed information about the trend line can be found if you place the mouse cursor over the trend line 
and leave it there for 2 seconds. 
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Trend Line Hover Popup 

 

Several operations for working on trend lines can be found by right mouse clicking on the line to show 
its context menu.   

1. Create Alert – Create an alert when the price crosses the trend line (see Component Alerts 
section) 

2. Show Info – Shows information about the trend line 
3. Show Angle – Displays the angle of the trend line (in degrees) 
4. Relative End Point – Calculates the end point relative to the start point instead of using a specific 

time/value for the end point 
5. Extend – Extends the Trend Line to the Right 
6. Extend Left – Extends the Trend Line to the Left 
7. Show Midpoint – displays the midpoint on the line 
8. Flip Line – Flips the values on the start and end points 
9. Circle Radius – Draws a circle using the trend line as the radius 
10. Circle Diameter – Draw a circle using the trend line as the diameter 
11. Rotate 90 Degrees – Rotates the trend line 90 degrees clock wise 
12. Rotate 45 Degrees – Rotates the trend line 45 degrees clock wise 
13. Make Lines Parallel – If you select multiple trend lines this will make them all parallel to the 

primary line (the one with the green resize points) 
14. Make Lines Parallel and Equidistant – If you select multiple trend lines this will make them all 

parallel to the primary line (the one with the green resize points) and equidistant between the 
top and bottom lines. 
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Trend Line Operations 

 

3.16.7 Visibility 

Note: This feature is not available in Analyst or Trade Editions 

Visibility is a very useful feature in MotiveWave™ that enables you to specify the bar sizes where a 
component is visible.  This can be very useful to avoid clutter when switching bar sizes on a chart.   
Visibility setting can be set from the Properties dialog or via the right click menu on the component. 

Visibility Menu 

 
Visibility Dialog 
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3.16.8 Object Viewer 

The Object Viewer is a convenient dialog for managing components on a chart from a single location.  
Component can be deleted from the chart and you can adjust the visibility and draw order.  The Object 
Viewer can be displayed from the top menu bar: View -> Display -> Object Viewer 

Object Viewer 

 

3.17 Ratios 

MotiveWave™ provides many different options for identifying time and price ratios.  Fibonacci ratios are 
perhaps the most commonly used ratios for analysis.  Available components for Fibonacci analysis can 
be found under the Fibonacci tab of the Components panel: 

Fibonacci Components 

 

Note: Components Panel is not available in the Trade and Analyst Editions of MotiveWave™.  Use the Mouse Tools available 
in the tool bar to create Fibonacci components. 

The screen shot below shows an example of a Fibonacci Retracement.  Yellow resize points can be used 
to change the position of the labels and length of the ratio lines. 
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Fibonacci Retracement 

 

MotiveWave™ provides a lot of flexibility for working with ratios.  If you would like to modify the ratio 
properties for a particular component, right click on a ratio label and choose Ratio Settings (or just 
double click on the label). 

Ratio Settings 

 

The Ratio Settings option will open the Properties dialog for the component and switch to the Ratios -> 
Ratios tab. 

Ratio Settings Dialog 
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From the Ratios tab, you can quickly select which ratios you want to display.  The available ratios are 
based on a Ratio Set (see drop down).  MotiveWave comes with several built-in ratio sets, but you can 
define your own in the Preferences dialog (see Ratios -> Sets tab). 

3.17.1 Customized Ratios 

If you would like more control over what ratios are displayed and the formatting for each ratio, check 
the Custom box from the Ratios tab of Properties dialog (see below). 

Custom Ratio Settings 

 

For each ratio, use the check box to the left to enable/disable.  The input field can be used to enter the 
ratio (in percent).  Click on the edit button to the right to specify how the ratio should be formatted. 

Ratio Settings Dialog 

 

The custom settings chosen above for this ratio will look like the following:  
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3.17.2 Ratio Preferences 

The Preferences tab allows you to change how the ratios are displayed.  Styles may be used to specify 
the default colors for the ratio lines, labels etc.  MotiveWave™ comes with several built-in styles, but you 
can define your own in the Preferences Dialog (Ratios -> Styles tab). 

Ratio Preferences 

 

3.17.3 Ratio Presets 

Ratio Presets can be very useful save a ratio configuration and apply it to another component.  This can 
help to avoid a lot of duplicate work.   Use the Save Preset button to save the current ratio configuration 
for later use. 
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Save Preset 

 

When you save the preset, you will need to choose a name.  Enter the name in the Save Ratio Preset 
dialog (see below) and click the Save button. 

Save Ratio Preset Dialog 

 

Right click on a ratio label and choose Ratio Preset -> <Preset Name> to quickly apply a preset to a 
component.  In the example below, we are going to choose Custom Preset 2 that we defined above: 

Apply Ratio Preset  

 

3.17.4 Global Ratio Preferences 

Global ratio preferences can be configured in the Preferences dialog from the Ratios tab.  This section 
has three sub tabs: Defaults, Sets and Styles: 
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Global Ratio Preferences 

 

The Defaults section enables you to assign the default preferences to each type of ratio component.  
Ratio components consist of retracements, fans, circles, Elliott Waves etc.  Each component type can 
have a default ratio Set, Style and preset. 

3.17.4.1 Ratio Sets 

Ratio sets are a convenient way to assign a group of ratios.  By default, MotiveWave™ is configured with 
four ratio sets: 

1. Normal Fibonacci – Common Fibonacci Ratios 
2. Extended Fibonacci – Extended set of Fibonacci ratios 
3. Gann – Common Gann ratios 
4. Extended Gann – Extended set of Gann ratios 

You can modify these default sets or define your own ratio sets. 
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Ratio Set Preferences 

 

3.17.4.2 Ratio Styles 

Ratio styles are useful for defining the appearance of ratios on a component.  This includes: 

1. Line, Label and Fill Colors 
2. Line Thickness 
3. Line Style (solid, dashed) 
4. Label Position (left, right variable) 
5. Ratio Fill 
6. Label Align 
7. Label Outline 
8. Show/Hide Price 

Several default ratio styles are included by default.  You can modify these styles or create your own (click 
on the New Style button).  The following screen shot shows the Styles tab: 
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Ratio Style Preferences 

 

3.18 Time/Price Guides 

Guides can be added to the vertical and time axes.  A guide is essentially a vertical (or horizontal) line 
that has an attached indicator to show its value.  There are two types of guides:  

1. Price/Value Guide – Displays a horizontal line with an attached indicator in the vertical axis  
2. Time Guide – Displays a horizontal line (across plots) with an attached indicator in the time axis 

Guides can be added to a chart from the right click menu of the axis (choose Add Guide).  This menu can 
also be used to edit the guide or remove it.  The location of the guide can be changed by clicking and 
dragging it. 
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Guides 

 
Guide Properties Dialog 

 

3.19 Percent Change Charts 

Note: This feature is not available in Analyst or Trade Editions 

Normally the price plot shows the historical prices.  Percent change charts are an alternate view that 
shows the change in the price between each bar as a percentage movement.  A percent change chart 
can be displayed by changing the bar type from the drop down on the tool bar to Percent Change. 
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Percent Change Chart 

 

By default, percent change charts are calculated from the left most point of the chart.  This can be 
changed to a specific bar by right clicking on the chart where you would like the calculation to begin.  

Percent Change from a Specific Bar 

 

Two dashed lines will be displayed to visually indicate where the charts are being calculated (see below). 
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Percent Change from a Specific Bar 

 

When combined with the Instrument Overlay, you can compare relative moves between instruments 
directly on one chart: 

Percent Change – Multiple Instruments 

 

3.20 Studies 

MotiveWave™ has over 275 built in studies that can be used to display information on the price plot or 
separately in a plot below the price.   

There are essentially two types of studies: 
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1. Overlays – display information that is drawn on top of an existing plot (most typically the price 
plot) 

2. Study Plots – display information that is displayed in a plot that is separate from the price plot.  

3.20.1 Adding a Study 

A study may be added to a chart by choosing one of the available studies can be found under the Study 
menu from the top menu bar.   This menu organizes some (not all) of the studies into logical groups 
(based on author or function).  The Add Study option enables you to search for a study instead of trying 
to find it in a sub-menu.  For convenience, a Recent menu is available to access recently used studies. 

Study Menu 

 

If you choose Add Study, you will see the following dialog.  This is a convenient way to search for a study 
by typing it in into the Filter input (see below): 

Add Study Dialog 
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When you add or edit a study you will see the study dialog similar to the one displayed below.  Each 
study will have different settings and configuration options.  The available tabs will depend on the study, 
but all study dialogs will have an Options tab and a Signals tab (if it generates signals).   

Study Dialog - SMA 

 

Adjust the settings for the study and click on the Create button to add the study to the chart.  For 
convenience, you can click on the Save Defaults button to save the study settings for the next time you 
create this study. 

The following screenshot shows the Simple Moving Average (SMA) study from the Study dialog above.  
Also shown is a Study Plot for the MACD study. 

Chart Studies 

 

3.20.2 Editing a Study 

If you would like to edit the settings on a study simply double click or right click and choose Edit Study. 
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Edit Study 

 

3.20.3 Study Options 

All studies will have an Options tab as the last tab when you create or modify its settings.  This tab will 
contain different values if it is an overlay or a study plot. 

Study Options - Overlay 
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Study Options – Plot 

 

3.20.3.1 Overlay Plot 

When you create an overlay study, by default it will use the Price Plot.  Optionally, you can choose one 
of the existing plots to display the study.  When you change the graph for the study, it will change the 
input options.  For example, if you want to display a simple moving average (SMA) on an RSI study plot, 
you would choose the RSI(C,14) plot from the Options tab.  When you choose this, the Input field (under 
the General tab) will be updated to reflect the inputs available from the RSI plot. 

   

 

3.20.3.2 Study Bar Size 

By default when you create a study, it will use the bar size of the chart.  When the chart bar size 
changes, the study will be automatically updated to reflect the new bar size.  MotiveWave™ does allow 
you to choose a specific bar size for the study.  This allows you to, for example, display a 5 minute EMA 
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(Exponential Moving Average) on a 15 minute chart.  This feature also applies to study plots so you could 
display a 10 minute RSI on a 15 minute chart (see example below): 

  

 

3.20.3.3 Study Plot Overlay 

Study plots may be overlaid on other plots.  You may have noticed this feature already with the Volume 
overlay on the default layout of the Console: 

Volume Overlay 
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You can change the overlay plot for a study from the Options tab.  A study plot can be overlaid on the 
Price Plot or other study plots.  The following examples show a CCI plot on the Price Plot and an RSI plot 
on a Stochastic plot: 

Plot Overlay 

 

3.20.3.4 Overlay Visibility 

Note: This feature is not available in Analyst or Trade Editions 

For convenience, you can specify that a study is only visible on certain bar sizes.  This is similar to the 
visibility feature for components.  By default a study is visible on all bar sizes.  You can change this from 
the Options tab: 

Overlay Visibility 

 

3.20.4 Signals 

Note: This feature is not available in Analyst or Trade Editions 
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Some studies generate signals.  Signals occur when a specific event occurs with the study.  For example, 
a signal may be generated in a CCI study where the CCI value crosses above the top guide.  These signals 
can be used to show alerts, play sounds or even send an email notification.  Note: if you want to send 
emails, you will need to configure your email (SMTP) settings in the Preferences dialog (Configure -> 
Preferences from the Console menu bar).  You will find these options under the Email tab. 

Study Signals 

 

3.20.5 Instrument Overlay 

Note: This feature is not available in Analyst Edition 

An instrument can be overlaid on top of the price plot by choosing Study -> Instrument -> Instrument 
Overlay from the top menu bar.  This action will open the dialog displayed below.  Type (or select from 
the drop down) the instrument that you would like to overlay in the Instrument field.  Click on the Create 
button to add this overlay to the price plot.  This dialog has the following elements: 

1. Instrument – Type or select the instrument.   
2. Bar Type – Choose the type of bar you would like to display for the overlay (default is a line 

chart) 
3. Line Source – If a line chart is chosen, this option allows you to choose the input source for that 

line (ie closing price, opening price etc) 
4. Shift – the number of bars to shift the study forward (negative value for backward).  Uncheck 

Lock Shift to enable dragging of the overlay backward or forward using the mouse. 
5. Style – For line charts, choose the color, thickness and style of the line. 
6. Show Axis – displays the axis for the instrument on the left hand side of the price plot 
7. Inverted – Click to display the overlay upside down 
8. Bar Updates – Click to enable live updates to the overlay instead of updates on the close of the 

bar 
9. Show Legend – Shows the overlay in the study legend area 
10. Show Label – Displays a label at the end of the overlay for the Instrument symbol 
11. Show Bars/Line – This may be used to hide the bars or line chart. 
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Instrument Overlay Dialog 

  

The example below shows an instrument overlay for the USD/CAD pair on top of the price plot for the 
EUR/USD pair.  The axis for the USD/CAD pair is displayed on the left hand side and has indicators for the 
current prices.  With Auto Scale enabled, dragging the chart left or right will automatically scale the 
values for the overlay. 

Instrument Overlay Example 

 

The vertical scale of the overlay can be adjusted by clicking and dragging the space between the overlay 
axis and the price plot.  Dragging from the top or bottom will add more top/bottom space.  Drag from 
the middle to adjust both at the same time. 
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Instrument Overlay – Vertical Space 

 

If auto scale is disabled, you can click and drag the overlay up or down to adjust the location of the 
overlay relative to the main instrument axis. 

Instrument Overlay – Adjust vertical location 

 

The horizontal location of the overlay can be adjusted by changing the value of the Shift field in the 
Instrument Overlay dialog.  A positive value will shift the overlay into the future and a negative value will 
shift it into the past.  If you uncheck the Lock Shift option you will be able to adjust the shift by dragging 
the overlay to the left or right with the mouse. 

andrey
tr-soft-collection
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Instrument Overlay Dialog – Disable Lock Shift 

 
Instrument Overlay – Shift  

 

3.21 Strategies 

Note: This feature is not available in Analyst or Trade Editions 

A strategy is a special type of study that may be used to automate or partially automate trading. In 
addition to displaying the study information, a Control Box is made available that allows the user to 
activate/deactivate a strategy and view important runtime information. 

MotiveWave™ supports two modes for strategies:  

1. Automatic – Once the user activates the strategy, it will automatically buy and sell based on the 
internal logic.  

2. Manual – In this mode, the user tells the strategy when it is OK to enter.  

MotiveWave™ comes with around 30 built-in strategies.  These can be found under the Strategy menu 
(from the top menu bar). 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 102 of 190 

 

Strategy Menu 

 

The following screen shot illustrates the Moving Average Cross strategy.  This strategy will buy when the 
Fast MA crosses above the Slow MA and sell when it crosses below (see triangle markers below).  Each 
strategy will have a control box (bottom left corner).  This will enable you to edit the strategy and 
activate it.  The control box also displays status information. 

MA Cross Strategy 

 

3.21.1 Manual Strategies 

MotiveWave™ allows you to create strategies that respond to user input to enter or exit a position. This 
can be very useful as a way to help direct and manage exit points for user initiated trades. For an 
example of how this works, see the Trade Manager strategy.  

The following screen shots show the configuration options for Trade Manager.  On the first tab 
(Entry/Exit) you can setup the entry order and up to 3 exit orders.  The Stop Loss tab provides options for 
the stop loss order.   



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 103 of 190 

 

   

From the Trade Manager Control Box, you can choose Long (buy) or Short (sell).  When you click the 
Activate button, the strategy will enter on the close of the bar.   

 

Once the strategy is active, the title bar will flash (indicates an active strategy) and the Activate button 
will be replaced by Cancel (deactivates the strategy) and Enter Now (creates a market order to enter the 
position). 

 

When a position is entered in the strategy, the labels in the control box will display the open position, 
current unrealized P/L (profit or loss), target P/L, stop P/L among other information. 
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3.21.2 Strategy Configuration 

The configuration options for a strategy will vary, but there are some settings that apply to many 
strategies.   

The first panel is the Trading Options panel.  This panel enables you to configure the following:  

Trading Options: 

1. Trade Lots – This determines the quantity on the orders that are used to entry and exit positions.  
The Trade Lot is multiplied by the default quantity to determine the actual quantity.  

2. Position Type – Use this option to indicate if the strategy can have long and/or short positions 
3. Enter On Activate – If enabled the strategy will create an initial position when you activate the 

strategy 
4. Close On Deactivate – If a position is open when the strategy is deactivated, it will be closed at 

market price. 
5. Bar Updates – If enabled, the strategy will respond to live bar updates instead of waiting until 

the close of the bar. 
6. Underlay – If enabled, the strategy will be drawn behind the price bars. 

Trading Sessions: 

The Trading Sessions section enables you to define sessions where the strategy may be active.  In 
between trading sessions, the strategy will be automatically deactivated. 

1. Session 1 – defines the first trading session with a start and end time 
2. Session 2 – defines the second trading session 
3. Time Zone – optionally specify the time zone for the hours defined in Session 1&2 
4. Close On Session End – Closes an open position when the session ends 
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Trading Options Panel 

 

Panel 

The Panel tab allows you to choose what labels are displayed on the control box.  The available labels 
will depend on the strategy. 

1. Show Position – displays the current open position 
2. Show Entry Price – shows the average entry price for the open position 
3. Show Unrealized P/L – shows the current unrealized profit/loss for the open position 
4. Show Realized P/L – shows the current realized P/L 
5. Show Stop P/L – shows what the profit/loss would be if the stop loss level is reached 
6. Show Target P/L –shows that the profit/loss would be if the target level is reached 
7. Show Risk Ratio – shows the risk level (target p/l divided by stop p/l) 
8. Show Total P/L – current total profit/loss since this strategy was activated 

Strategy Panel Options 
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3.22 Software Development Kit (SDK) 

Custom studies and strategies can be programmed using our Software Development Kit.  For more 
information on this, please visit our website: http://www.motivewave.com/support/sdk.htm 

3.23 Tool Bar 

A tool bar is available from the Console or from a Chart Window and contains a convenient set  of 
buttons for performing common operations on a chart.  This tool bar may be configured from the 
Preferences dialog (Configure -> Preferences from the Console menu bar).  Additional tool bars may be 
added to the bottom or sides of the window. 

Actions can be added or removed from a tool bar by selecting them on the right side (to add) or left side 
(to remove or re-order) and use the left and right arrow buttons in the center.  You can re-order the 
buttons and add separators (or spacing) by selecting the action on the right and side and using the 
buttons to the far right. 

Tool Bar Preferences 

 

Additional tool bars can be added to the windows by selecting the desired tool bar from the drop down 
and checking the Enabled box to the right.   The Compact option is for changing the buttons that are 
available on the tool bar when in Compact Mode. 

http://www.motivewave.com/support/sdk.htm
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Top2 and Left Tool Bars Enabled 

 

3.24 Lock Studies 

The Lock Studies feature is a convenient way to keep the current set of studies on a chart when you 
change the instrument.  Choose View -> Lock Studies from the top menu bar to enable this feature on 
the selected chart.   To change the instrument on a chart, type the new symbol into the Quick Search 
box on the left side of the tool bar and press the Enter key. 

The following two screen shots illustrate the usage of the Lock Studies feature 
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Enable Lock Studies 

 
Lock Studies – Change Instrument 

 

3.25 Lock Scroll 

Lock scroll is a convenient way to maintain the same position across multiple charts when using the 
scrolling feature to move forward or backward on the historical price axis.  Choose View -> Lock Studies 
(from the top menu bar) or use the button available on the tool bar to enable this feature.  
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When this feature is enabled all charts that are part of the same Link Group will scroll to the same 
position when one of the charts is scrolled.  If the chart is not part of a link group, but rather on a 
Console page.  All charts that are on the same page will scroll with chart. 

Enable Lock Scroll 

 
Lock Scroll Enabled 

 

3.26 Study Templates 

Note: This feature is not available in Analyst or Trade Editions 
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For convenience, studies can be organized into templates.  A template contains one or more studies 
with specific settings.  To create a template, simply add and configure all of the studies you want to 
include on a chart.  When you are satisfied with the studies and their settings, choose File -> Template -> 
Save As Template (from the top menu bar, Note: File -> Chart -> Template -> Save As Template from the 
Console). 

Create Template (Step 1) 

 
Save As Template Dialog (Step 2) 

 

A study template can be applied to another chart by choosing File -> Templates -> <Template Name> 
from the top menu bar (Note: File -> Chart -> Templates -> <Template Name> from the Console).  Short 
cut keys are available to make this more convenient.   Short cut keys are Alt + 1, Alt + 2 etc where the 
number key applies the template in the order they were created. 
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Apply Template 

 
Template 

 

3.26.1 Removing a Template 

To remove a template from a chart (including any associated plots).  Right click on the template name (in 
the study legend). 

Remove Template 
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3.26.2 Managing Templates 

Your existing templates can be managed from the Manage Templates dialog.  Choose File -> Templates -
> Manage Templates (from the top menu bar).  From this dialog you can rename, delete or change the 
order of the templates.  The template order affects the short cut keys (Alt + 1, Alt + 2 etc).  Changing the 
order will affect which template applies to each short cut key sequence. 

Manage Templates Dialog 

 

3.26.3 Template Preferences 

Preferences for study templates can be found in the Preferences dialog.  Click on Chart then on 
Templates.  A default template can be configured (check the Use Default option).  This will be displayed 
whenever you create a new chart. 

The Link Templates option will apply a template to all charts that are part of the link group (if configured, 
see the Chart Linking section). 

Template Preferences 
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3.27 Linking Charts 

Note: This feature is not available in Analyst or Trade Editions 

Chart linking is a powerful feature that enables you to apply an action to a set of charts (instead of a 
single chart at a time).  By default charts are unlinked (no link group assigned).  There are a few different 
ways to assign a link group to a chart.  The simplest is to choose the link group from the status bar at the 
bottom of the window (Note: this also works for DOM and Time/Sales windows).  

Link Chooser 

 

There are two modes for linking charts: 

1. Instrument (Symbol) – In this mode, changing the symbol on one chart will change all charts in 
the link group to the same symbol 

2. Time (Bar Size) – If the bar size is changed on a chart in this mode, all linked charts will change to 
the same bar size  

By default, charts are linked using the instrument.  This mode can be changed by choosing View -> Link -
> Link Instrument / Link Time from the top menu bar. 

Link Mode 

 

Other windows such as the DOM and Time/Sales windows can also be given a link group.  In the example 
below, two charts and a DOM Window have been assigned the same link color.  Choosing a new symbol 
from the quick search box from one of the windows will automatically change the symbol for all 
windows in the link group. 
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Linked Example Step 1 

 
Linked Example Step 2 

 

3.27.1 Linking With Templates 

As discussed in the Study Templates section the linking feature can be used in conjunction with the 
Study Templates.  If enabled (see Preferences Dialog, Chart -> Templates tab), applying a template to 
one chart in the link group will apply the template to all charts in the link group. 
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3.27.2 Link All 

If you are working with the Console window (or a Chart Group), you will notice an additional linking 
option, Link All.  This option will link all charts that are on the current page.  This provides a convenient 
way to link all the charts on a page with one click (instead of choosing a link for each chart).  

Link All Charts 

  

3.28 Working with Chart Windows 

3.28.1 Compact Mode 

Note: This feature is only available on Windows  

Compact mode strips away the title bar, tool bar, menu bar and status bars to maximize the chart area 
on a chart window.  Use the compact/uncompact button on the right hand side of the title bar to switch 
between regular and compact modes. 

Compact Button 

 

The screen shot below illustrates a chart window in compact mode.  Notice that the chart area fills the 
entire window to optimize the use of screen space.  A smaller version of the title bar and tool bar are 
available at the top and left hand side of the chart (respectively).  These elements can also be hidden by 
clicking the ‘pin’ button.  With this button turned off they will automatically hide when you move the 
cursor away.  Click on the uncompact button on the tool bar to return to normal mode. 
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Compact Mode 

 

3.28.2 Tile Windows 

The Tile Windows feature is useful to arrange your charts on a single monitor without having to position 
the windows manually.  Start by arranging the chart windows roughly where you would like to place 
them.  Once you have done this, right click on the title bar of one of the chart windows and choose Tile 
Windows (alternatively, press Ctrl + W).  Note: on Mac OS X choose Window -> Tile Windows from the 
top menu bar. 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 117 of 190 

 

Tile Windows Before 

 
Tile Windows After 

 

3.28.3 Cascade Windows 

Similar to the Tile Windows feature, Cascade Windows arranges the windows that are on the screen on 
top of each other offset from the top left corner.  Choose Window -> Cascade Windows from the top 
menu bar to arrange the windows in this fashion. 
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Cascaded Windows 

 

3.28.4 Window Sizes 

For convenience, the window size can be set from the Window menu (Window -> Window Size -> 
<Size>).  This can be a useful feature for taking a screen shot or video.  Choose Custom to specify a size 
that is not one of the presets. 

Window Sizes 
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3.29 Replay Mode 

Note: This feature is not available in Analyst or Trade Editions 

Replay mode is a very useful feature that enables you to go back in time and replay market data.  This 
can be very useful to practice your trading or to test your custom studies and/or strategies.  The replay 
mode control can be accessed from the chart menu bar: View -> Replay Mode (Note: there is also a 
button on the right hand side of the tool bar).  When you click this menu item you will see the Replay 
Mode control appear on the chart. 

Displaying Replay Mode 

 

Replay mode can be started by choosing a start date and pressing the power button. 

Turn On Replay Mode 

 

Use the play, fast forward, reverse and stop buttons to step forward through the data.  These buttons 
work as follows: 

1. Rewind – This will restart the replay mode from the beginning 
2. Play – Step forward in time by 1 tick 
3. Forward – Play ticks until the next bar is reached 
4. Fast Forward – Play ticks continuously 
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5. Stop – Stop playing ticks.  This is only active if forward or fast forward buttons have been clicked 
above. 

Replay Buttons 

 

When you are working in replay mode will work as if you are trading live back in that time frame.  A 
special replay account is created to manage orders, positions and historical trades. 

3.29.1 Replay Settings 

Replay settings can be accessed by clicking the wrench icon on the right hand side of the Replay Mode 
control. 

Replay Settings Dialog 

 

Replay Data Settings: 

The following settings apply to the playback of data in replay mode: 

1. Source Data – Options for source data include: 
a. Bar Data – Each bar is used to generate 4 ticks: open, high, low and close 
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b. Minute Data – Minute data will be loaded from the data service to generate ticks (each 
minute bar will have 4 ticks: open, high, low and close 

c. Tick Data – If your broker/data service provides historical tick data, then this may be used 
2. Generate Ticks – If this is enabled MotiveWave will generate a set of ticks to (beyond OHLC) for 

playback.  This option does not apply to the Tick Data option 
3. Tick Delay – this is the delay to add between the play of each tick. 
4. Real Delay – If this option is checked, MotiveWave will simulate the delay between ticks by using 

the tick timestamps.  Use this if you would like to simulate the actual playback of ticks in real 
time 

5. Bar Delay – this is the delay to wait between the playback of each bar. 
6. Replay Link – Use these options to link the replay mode across multiple charts. 

Replay Account: 

The replay account is useful if you intend to place trades in replay mode.  If this is enabled, a special 
account will be created (see Account page in the Console) to track all orders, positions and historical 
trades for the replay session. 

1. Trade Enabled – Make sure this box is checked if you intend place trades in replay mode 
2. Account ID – This is the name of the account ID that will track trades 
3. Base Currency – This will default to your base currency, but you can change it if you like 
4. Cash Balance – Opening cash balance when you enable replay mode 
5. Include Commissions – Check if you want trade commissions to be included in the P/L 

calculations. 

3.29.2 Linking in Replay Mode 

The linking feature in MotiveWave™ enables you to use replay mode across several different charts at 
the same time.  The following steps explain how to include multiple charts in the same replay session:  

1. Select the charts that you want to include and choose the instruments and bar sizes 
2. Choose the same link color for each chart 
3. Edit the Replay Settings 
4. Choose Linked Charts and press the “Update” button 

Replay Linked Settings 

 

The following screen shot shows 4 charts that are part of the Red group and using the same replay 
session: 
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Replay Session - Linked Charts 

 

3.30 Alerts 
Note: alerts are not available in the Analyst or Trade Editions 

Alerts are a useful way to receive a notification when a particular event has occurred.  This could be as 
simple as a price for a particular instrument has been reached or a trend line has been crossed.  More 
advanced examples include comparing values from different studies.   

Active alerts can be managed centrally from the Alerts panel in the Console.   By default, this is included 
on the Home page.  You can add an alerts panel anywhere in the console from the Add Tab button to 
the right of any panel tab. 
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Alerts Panel 

 

3.30.1 Price Alerts 

The simplest type of alert is a Price Alert.  A price alert does not require a chart in order to execute.  It 
will triggered by the bid/ask or last price of an instrument.  Price Alerts can be created directly from the 
Alerts panel or from the Price Axis of a chart. 

Create Price Alert – Alerts Panel 

 
Create Price Alert – Price Axis 

 

The following dialog is shown when an alert is created from the Alerts panel.  Alerts created from the 
Price Axis are similar except for the ability to choose an instrument (this is assumed from the chart).  
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Create Alert Dialog 

 

Settings available in this panel are as follows: 

1. Parameters 
a. Condition – This defines the criteria for triggering the alert.  The first field (input) can be 

the Last Price (if available) Best Bid or Best Ask.  The last field can be an absolute price.  
Alternatively, it could be a relative value (click the Indicator box) such as Last Price, Best 
Bid or Best Ask.  In the case of a Price Alert, this will be an absolute value in most cases.  
Three types of operators are available for comparison: 

i. Crosses – Input crosses above or below the second input 
ii. Crosses Above – Triggers the alert only if it crosses above the second input 
iii. Crosses Below – Triggers the alert only if it crosses below the second input 
iv. Touches – Triggers an alert if the target value is touched or crossed 

b. Trigger Multiple – If this option is checked, the alert will still be valid after it is first 
triggered.  In this case this alert will be triggered indefinitely until it is explicitly cancelled.  

c. Label / Comments – These fields enable you to add your own text to an email notification 
that is sent when the alert is triggered 

2. Notification 
a. Show Alert – If true the Alert History window will be displayed when the alert is triggered 
b. Play Sound – A sound will be played when the alert is triggered.  This can either be the 

preset sound or a specific sound file that you can specify. 
c. Send Email – If enabled (and email sending has been configured), an email will be sent to 

the given email address when the alert is triggered. 

3.30.2 Study Alerts 

Alerts can be based on values that are generated as part of a study.  These types of alerts execute in the 
context of a chart and require the chart to be open in order to be active.  Similar to a price alert, you can 
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create a study alert by right clicking on the vertical axis (of the Price Plot or a Study Plot) and choosing 
Create Alert. 

Create Study Alert 

 
Create Study Alert Dialog 

 

Two types of comparisons can be made with a study alert: 

1. Absolute Comparison – A study value is compared to a specific value (ie 0.1629 in the above 
example) 

2. Relative Comparison – A study value is compared against another study value (in the same plot).  
Click on the Indicator field to enable a relative comparison. 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 126 of 190 

 

Relative Comparison 

 
 

The example below illustrates a study alert where the value of one study KAMA(C,20) crosses the value 
of another study (Tenkan-Sen(9)).  The alert is displayed where the intersection point would be between 
these two values. 

Study Alert – Relative Comparison 

 

3.30.3 Component Alerts 

Some components can be used to generate alerts.  For example, you could create an alert for when a 
moving average crosses a trend line.  If you would like to create this type of alert, right click on a trend 
line and choose Create Alert. 
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Create Component Alert 

 
Component Alert Dialog 

 

In the example below the study value KAMA(C,20) was chosen to cross the trend line.  The alert label 
shows the current crossing value.  Press the ‘C’ button to cancel the alert.  The alert may be edited by 
double clicking the alert label or via right click and choosing Edit Alert. 

andrey
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Trend Line Alert 

 

3.30.4 Trading From Alerts 

Trades can be placed when an alert triggers.  Click on the Trade tab of the alert dialog to define an order 
that will be placed when the alert is activated. 

Alert - Trade Options 

 

Orders can be placed on a different instrument from where the alert was triggered.  Market, Limit and 
stop orders are supported as order types. 

3.30.5 Advanced Alert Settings 

Additional options on an alert can be specified from the Advanced tab.  This tab enables to you adjust 
time times when the alert is applicable (or expires) and the display properties.  
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Alert – Advanced Settings 

 

Time In Force 

The Time In Force section allows you to set an expiry date/time for an alert and optionally define times 
of the day when the alert is active.   

1. Time Zone – The dates and times specified in this section will use the same time zone defined for 
the chart.  This may optionally be overridden by unchecking the Use Default box. 

2. Expires – Check the Enabled field to the right to specify a date/time when the alert will expire 
and be removed. 

3. Session 1 – Defines a time of the day when the alert will be active 
4. Session 2 – Define a secondary time of the day when the alert will be active. 

Display 

The Display section allows you to override default display attributes for the alert. 

3.30.6 Alert History 

The Alert History window displays alerts that have been triggered in the past.  Choose View -> Display -> 
Alert History Window from the top menu bar.  If the chart where they were activated is still available, a 
Chart button will be available to view the chart that they originated from. 
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Show Alert History Window 

 
Alert History Window 

 
 

Historical alerts are also visible directly on the chart.  Icons are displayed when and where (what price) 
and alert occurred.   If you place the mouse cursor over one of the alarm clock icons, you can view 
detailed information. 

Historical Alerts on the Chart 

 

3.30.7 Alert Preferences 

Global alert preferences can be configured in the Preferences dialog (Configure -> Preferences from the 
Console menu bar).  The alert preferences will be found under the Alert tab (see below). 
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Alert Preferences 

 

3.31 Ticker Tape 

Ticker tape displays a rolling set of prices for a selected set of instruments across the top of the Console, 
Chart Group or Chart Window.  This option can be turned on by choosing View -> Display -> Ticker Tape 
from the top menu bar. 

Show/Hide Ticker Tape 

 

The instruments and display of the ticker tape can be configured from the Preferences dialog (Configure 
-> Preferences from the Console menu bar).  Click on the General tab, then on the Ticker Tape sub tab.  
This panel has the following options: 
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1. Instruments – Instruments may be added or removed by using the tool bar at the top of the list 
box on the left 

2. Font – Font size for the instruments displayed on the ticker tape section 
3. Scroll Type – Choose from the following: 

a. None – No scrolling 
b. Scroll – Tape continuously scrolls to the left 
c. Slide – Tape slides to the left at an interval 

4. Scroll Speed – Relative speed for scrolling the instruments 
5. Show Ticker Tape – Default for displaying the ticker tape in a chart window 
6. Show Change – Shows the change since the day open 
7. Show Change % - Shows the change since the day open as a percent 

Ticker Tape Preferences 

 

3.32 Short Cuts 

MotiveWave™ provides a number of convenient ways to do common tasks quicker.  This section 
explores some of these options. 

3.32.1 Menu Short Cut Keys 

You may have noticed already that when displaying a menu, a key combination is displayed on the right 
hand side for some of the items in that menu.  This key combination may be used as a short cut to 
access that item without using the mouse to show the menu and select the item. 

In the example displayed below, the short cut keystroke for accessing the Line tool is: Ctrl + Shirt + L.  
This means that you can hold down on the Ctrl (Control key), Shift and press the L key on the keyboard 
(all at the same time) to switch your mouse tool to the line tool.  You may find this to be much faster 
than using the mouse to select the tools drop down and choose the line tool menu item. 
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Keyboard Short Cuts 

 

Please Note: by convention tool short cuts all have the sequence Ctrl + Shift + <key>.  This makes it 
easier to remember them. 

3.32.2 Mouse Wheel 

If your mouse has a wheel, you can use this to perform the following actions on the chart: 

1. Time Shift – Move the graph to the left or right (depending on wheel direction) 
2. Adjust Bar Width – This will effectively zoom the graph in or out 
3. Adjust Vertical Space – Changes the space available at the top or bottom of the graph 

The default action for the mouse wheel is to time shift when it is moved back or forward.   If you hold 
down on the Alt key and move the mouse wheel, it will adjust the bar width (ie zoom in or out).  

This behavior can be adjusted from the Preferences dialog (Configure -> Preferences from the Console 
menu bar).  Click on the General tab, then on the Mouse sub tab. 
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Mouse Wheel Preferences 

 

3.32.3 Mouse Click Options 

Keyboard modifiers: Shift, Ctrl and Ctrl + Alt when used with a left mouse click can be configured to do 
specific actions.  The default behavior is as follows: 

1. Shift + Click – Creates Text Comment.  When you perform this short cut an entry box will appear 
for you to enter text.  Just type your comment and press Enter (or Esc) to create it.  

2. Ctrl + Click – Creates a Price Guide at the location of the mouse. 
3. Ctrl + Alt + Click – Creates a Time Guide at the location of the mouse. 

These actions may be configured from the Preferences dialog (Configure -> Preferences from the 
Console menu bar).  Click on the Chart tab then on the Chart Settings sub tab.  The following actions are 
available to choose from for each click shortcut: 

1. Price Guide – Creates a price guide at the mouse location 
2. Horizontal Line – Creates a horizontal line at the mouse location (extended left and right)  
3. Time Guide – Creates a time guide at the mouse location 
4. Vertical Line – Creates a vertical line (extended up and down) at the mouse location 
5. Text – Creates a text box to enter text 
6. Note – Creates a Note component  
7. Box Callout – Creates a Box Callout component 
8. Balloon Callout – Creates a Balloon Callout component 
9. Line Callout – Creates a Line Callout component 
10. Annotation – Creates an Annotation component 
11. Curly Annotation – Creates a Curly Annotation component 
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Mouse Click Shortcuts 

 

3.32.4 Other Shortcuts 

The following are some other shortcuts that you may find useful. 

Ctrl + Mouse Drag (Copy) 

Hold down on the Ctrl key and drag a component to create a copy of it.  This can be very useful for 
example to create a line that is parallel to another line.  The mouse cursor will change to the following to 

indicate that you are creating a copy:  

Copy Line 
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Revert To Default Tool (Space Bar) 

When switching to a mouse tool, you can quickly switch back to the default mouse tool (Time Drag Tool) 
by pressing the Space Bar.  This can be more convenient than pressing Ctrl + Shift + D.  Alternatively, you 
can change the behavior of the mouse tools to automatically revert to the default tool when an action is 
completed.  This can be adjusted from the Preferences Dialog.  Click on the Chart tab then on the Chart 
Settings tab.   

Default Mouse Tool 
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4 Trading 
Note: Trading features are not available in the Analyst Edition 

There are lots of ways to place and manage trades within MotiveWave™.  In this section will explore 
some of the convenient features for dealing with orders, positions and trades.  Some of the trading 
features such as supported order types may vary depending on the broker you have chosen for the 
workspace. 

4.1 Account Management 

The Account page in the console provides a convenient view of current account information as well as 
open orders, positions and historical trades.  The columns displayed in each section will vary depending 
on the broker or data service that you chose for your workspace. 

Account Page 

 

This is the default layout for the Account page.  You can add these panels anywhere within the Console 

or Chart Group.  Simply click on the Add Tab  button next to the existing tab where you want to add 
the panel.   
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Add Account Mgmt Panel 

 

4.1.1 Accounts Panel 

The Accounts panel displays information about each available account in your workspace.  The columns 
displayed will differ depending on the broker that you chose for your workspace.  The Unrealized PL 
column is common to all brokers and displays the current unrealized profit/loss for all positions that 
belong to each account.    

Accounts Panel 

 

The Primary column indicates which account is the default for placing orders.  You can change the 
primary account by right clicking on the desired account and choosing Set As Primary Account.  This 
setting is important to avoid accidentally placing orders on the wrong account. 

Primary Account 
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4.1.2 Orders Panel 

The Orders panel displays the currently active orders in one convenient location.  The Group column 
indicates orders that are linked as either OCO (One Cancels Other) or OSO (One Submits Other).   The 
Status column displays the current order status (green for active).  Click on the ‘C’ to cancel an active 
order. 

Orders Panel 

 

Orders can be edited from here directly by clicking on the appropriate table cell (see below).  If an order 
has outstanding changes, the status column will change to show a ‘T’ and a ‘D’.  Click on the ‘T’ to 
transmit (submit) the changes to the broker or on ‘D’ to discard the changes. 

Edit Order 

 

Alternatively, right click an order to see additional options.  Double clicking on an order will show the 
Order Ticket Dialog. 

Orders Panel Options 
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4.1.3 Positions Panel 

The Positions panel shows the currently open positions (and closed for some brokers).  Individual 
positions can be closed (at market price) by clicking on the Close button (right hand side).  If you would 
like to close all positions, right click on a position and choose Close All Positions. 

Positions Panel 

 

If you have enabled the simulated account, you can add positions manually by clicking the Add Position 

 button on the top right corner of the panel.  This is a useful feature if you would like to track 
positions that are managed outside of the broker or data service that you are using.  The following 
diagram shows the Add Position dialog.  It has the following fields: 

1. Instrument – select the symbol for the instrument 
2. Opened Date – This is when the position was originally opened 
3. Quantity – Number of shares, contracts etc 
4. Avg Price – Average entry price for the position 
5. Commission – Optionally enter a commission to track fees. 

Add Position Dialog 

 

For some brokers (such as FXCM) they provide a bit more information on position such as the recently 
closed positions.  Specifically for FXCM hedging accounts, a summary tab is included to roll up individual 
position totals. 
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Open Positions – FXCM (Hedging) 

 
Summary Positions – FXCM (Hedging) 

 
Closed Positions - FXCM 

 

4.1.4 Trades Panel 

The Trades panel displays historical trades (ie filled orders).  Columns displayed on this page will vary 
depending on the broker chosen for the workspace.  Some brokers only report a limited number of 
historical trades.  For this reason, you should rely on the account management tools provided by your 
broker to ensure accurate reporting of historical trades. 

andrey
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Trades Panel 

 

4.2 Simulated Account 

For convenience, MotiveWave™ has a built in simulated account that you can use to practice your 
trading.  If you chose a data service for your workspace, then this account will be enabled by default.  If 
you are using a broker, it is recommended that you use a demo account if provided by your broker 
instead.  Broker demo accounts will provide a better simulation of their trading environment and 
supported order types and behaviors. 

The simulated account can be configured from the Preferences Dialog (Configure -> Preferences from 
the Console menu bar).  Click on the General tab then on the Simulated Account tab.  This panel has the 
following fields: 

1. Enabled – Check this box to enable or disable this account 
2. Base Currency – Base currency for the account 
3. Case Balance – Initial Cash Balance 
4. Fill Immediate – If checked market orders will be filled immediately at the current bid/ask value 

instead of waiting for the next trade 
5. Include Commission – If checked, commissions will be included when placing trades. 
6. Reset Account Button – Click this button to reset the account back to the initial cash balance. 
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Simulated Account Preferences 

 

If you have the simulated account enabled, you will see an entry in the Accounts panel for this account.  
The account id will be ‘simulated’. 

Simulated Account 

 

4.3 Commissions 

Commissions can be calculated by MotiveWave™ using the simulated account, in replay mode or as part 
of Strategy Back Testing.  If you would like to include commissions, these can be configured from the 
Commissions dialog (Configure -> Commissions from the Console menu bar).   

1. Base Cost – This is the base cost of a trade.  Some brokers offer flat rates for commissions.  If this 
is the case, just enter the cost here. 

2. Unit Cost – Some brokers charge based on the number of units (ie quantity) that are part of an 
order (ie shares, contracts etc).  

3. Unit Size – If a unit cost has been specified this is the lot size. 
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Commissions Dialog 

 

The above dialog enables you to define a commission structure that applies to each type of instrument.  
Some instruments may have their own specific commission structure.  If this is the case, you can 
override this from the Instrument dialog (right click on the chart and choose Edit Instrument, click on the 
Commissions tab). 

Instrument Commissions 

 

4.4 Order Presets 

Order presets are convenient for defining default order attributes.  Defaults can be defined generically 
by the type of instrument or specific to an instrument.  General order presets can be accessed by 
choosing Configure -> Order Presets from the Console menu bar. 

This dialog has a tab for each type of instrument.  Each panel will have the following fields:  

1. Order Type – Default type of order to be placed 
2. Time In Force – Defines the expiration time of the order.   Available types will depend on the 

broker.   
3. Trigger OTH – If checked, the order can be triggered outside of regular trading hours 
4. Offset – Default offset (in pips) from the current price when placing an order 
5. Limit Offset – Default offset (in pips) from the current price when placing a limit order 
6. Stop Offset – Default offset (in pips) from the current price when placing a stop order 
7. Trail Offset – Default offset (in pips) from the current price when placing a trail order 
8. Default Quantity – Default quantity when creating a new order 
9. Increment – Increment (or decrement) size when adjusting the order quantity 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 145 of 190 

 

10. Preset Quantities – The quantities in the list box will be available from a drop down menu next 
to each quantity field.  These values are also available from Quantity Selector in the DOM. 

General Order Presets Dialog 

 

If you would like to change the order presets for a specific instrument, edit the instrument (right click on 
a chart and choose Edit Instrument) and click on the Order Presets button at the bottom of the dialog. 

Edit Instrument Dialog 
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Order Presets - Instrument 

 

4.5 Chart Trading 

Perhaps the most convenient way to create orders in MotiveWave™ is by using the tools available from 
a chart.  There are several ways to do this: 

1. Price Axis – Trades can be placed directly from the price axis 
2. Buy/Sell buttons – The Buy/Sell button labels can be optionally added to a chart 
3. Context Menu – Use the trade items available in the context menu of the chart (right click) 
4. Trade Panel – Use the trade panel that may be displayed on the right hand side of the chart  
5. DOM Panel – The Depth of Market panel can be displayed on the right hand side 
6. Strategies – As explained in the section: Strategies 

4.5.1 Chart Orders 

Active and filled orders may be displayed and adjusted directly on the chart.  Click on the Show Orders 
 button on the tool bar to toggle the display of orders on the chart.  
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Chart Orders 

 

The price of an order can be adjusted by clicking and dragging the order label up or down.  When the 
desired price is set, click on the ‘T’ button to transmit the change to the broker. 

Adjust Chart Order Price 

 

Double click on the order label to display the Order Ticket Dialog.  A context menu can also be accessed 
by right clicking on the order label. 
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Order Context Menu 

 
 

4.5.2 Trade History 

Historical trades can be displayed directly on the chart by clicking the Show Trades  button on the tool 
bar.  Detailed information on each trade can be displayed by placing the mouse cursor over one of the 
trade arrows. 

Trade History 

 

4.5.3 Price Axis Trading 

Orders can be created directly from the price axis by simply clicking where you want to place a limit 
order.  If you move the mouse over the price axis, you will notice that the mouse cursor will change to a 
blue/red target (depending if you are above or below the current price).  You will also notice that there 
is a label that shows the price.   
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Price Axis Trading – Limit Buy Order 

 

Press the left mouse button once to create a limit order at that price using the default quantity for the 
Instrument (see Order Presets).  Note: place the cursor above the current price to create a Limit Sell 
order, and below to place a Limit Buy order. 

By default, this order will just be created (not submitted to the broker).  You can optionally modify this 
order and click the ‘T’ (transmit) button to submit the order to the broker. 

Price Axis Trading – Adjust Order 

 

4.5.3.1 Price Axis Order Types 

You can place different types of orders from the price axis by holding down on the following keys while 
clicking the left mouse button.  The quantity for all of these orders will be the default quantity assigned 
to the instrument. 
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1. No Key – Limit Order, the limit price will be the value at the current mouse location  

a.   Limit Buy – cursor is below the current price 

b.   Limit Sell – cursor is above the current price 
2. Ctrl Key – Stop Order, the stop price will be the value at the current mouse location 

a.  Stop Buy – cursor is above the current price 

b.  Stop Sell – cursor is below the current price 
3. Shift Key – Market Order, sell or buy at the current market price (best bid/best ask) 

a.  Buy Market – cursor is below the current price. 

b.  Sell Market – cursor is above the current price 
4. Ctrl + Shift Key – Limit Order + Attached Limit & Stop orders.  A limit order will be placed with 

the limit price equal to the current mouse location.  A limit and stop loss order will be attached 
to the limit (parent) order. 

a.  Buy Limit + Sell Stop/Limit 

b. Sell Limit + Buy Stop/Limit 

The mouse cursor will change depending on which modifier key you are pressing when moving the 
cursor over the price axis. 

4.5.3.2 Price Axis Context Menu 

The context menu (right click on the price axis) also has a menu for creating orders (see diagram below). 

Price Axis Trade Menu 
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4.5.4 Buy/Sell Buttons 

For convenience, buy and sell buttons can be added to the chart.  These buttons are available as Chart 
Labels.  Double click on the chart (or right click and choose Chart Settings) to open the Chart Settings 
dialog.  You will find the Buy Button and Sell Button labels under the Label tab. 

Enable Buy/Sell Buttons 

 

If you would like to create a buy or sell order, click on the Buy or Sell buttons that are directly on the 
chart.  This will open an Order Ticket dialog that you may use to create your order. 

Buy Sell Buttons 

 

The Order Ticket dialog may look different depending on the broker you are using.  The following dialog 
is from a workspace configured for FXCM: 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 152 of 190 

 

Order Ticket Dialog 

 

4.5.5 Context Menu 

The context menu (right click on the chart area) has options for placing orders and adjusting trading 
settings. 

Context Menu – Trading Options 

 

4.5.6 Trade Panel 

The trade panel is a convenient tool for managing orders and positions from the chart.  This panel can be 
displayed by choosing View -> Display -> Trade Panel from the top menu bar (or press Alt + T).  There is 

also a button  available on the tool bar that toggles the display of this panel. 

The Trade Panel has three tabs that provide different trading options. 
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4.5.6.1 Position Tab 

The Position tab may be used to manage your current position for the chart instrument.  It has the 
following elements: 

1. Buy Market Button – Creates a market order to buy the given quantity at the market price 
2. Sell Market Button - Creates a market order to sell the given quantity at the market price 
3. Quantity – This is the quantity for the market orders.  It will default the value in order presets  
4. Flatten Button – If you currently have an open position, this button will close the position at 

market price 
5. Cancel All – If you have open orders for the chart instrument, this will cancel these orders 
6. Reverse Button – If you have an open position this will close that position and open a position in 

the opposite direction.  For example, if you were currently long 10K, this would close the long 
position and open a short position for 10K 

7. Account Choice – Enables you to choose the account for the orders 
8. Position Label – Displays the current position (N/A for no position).  If the label background is 

blue, then the position is long.  Short positions will have a red background as well as a negative 
number for the quantity.   

9. P/L Label – Displays the current unrealized profit/loss for the open position.  A loss will be 
displayed with a red background (and a negative sign).  A profit will be displayed with a blue 
background.  If there is no open position, this label will display N/A. 

Trade Panel – Positions Tab 

 

4.5.6.2 Order Tab 

The Order tab is used to create or modify existing orders.  New orders can be created by clicking on the 
Buy or Sell buttons.  An existing order can be modified by selecting it on the chart (left click on the label).  

1. Buy Button – Indicates if the order is a buy or sell.  If no order is selected on the chart, you may 
click on this button to create a buy order. 

2. Sell Button – Indicates if the order is a buy or sell.  If no order is selected on the chart, you may 
click on this button to create a sell order. 

3. Quantity – quantity for the selected order.  This will default to the order preset if it is a new 
order. 
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4. Order Type – list of available order types (broker dependent).  The selected choice will influence 
the visible fields below (ie limit price, stop price etc). 

5. Limit/Stop Price – Depending on the type of order these fields may be visible underneath the 
Order Type field. 

6. Time In Force – effective time for the order.  Day orders will expire at the end of the day.  GTC 
orders last until they are cancelled (Good Till Cancelled).  The options available in this field will 
vary depending on the broker. 

7. Submit/Modify Button – Click this button to submit the order to the broker.  This button will 
have a red background for sell orders and a blue background for buy orders 

8. Discard/Cancel – Discards (for new orders) or cancels the order 
9. Account Choice – Account for the order.  For new orders, this will default to the Primary account 

(set in the Accounts panel). 

Trade Panel – Order Tab 

 

4.5.6.3 Bid/Ask Tab 

The Bid/Ask tab shows a Buy/Sell box (with best bid and best ask prices).  This tab is convenient for 
placing buy and sell orders at market and monitoring the spread between the bid/ask prices.  You can 
double click on either the Sell or Buy boxes to submit a market order. 
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Trade Panel – Bid/Ask Tab 

 

4.5.6.4 Entry/Exit Strategies 

Entry/Exit strategies provide a convenient way to place combinations of orders in a single click.  The 
entry/exit section can be found on the Trade Panel as well as the DOM (Depth of Market, hidden by 
default). 

The following screen shot shows the Entry/Exit section of the Trade Panel.  Strategies can be created, 

modified or removed by clicking on the edit  button located in the top right corner of the section. 

If you would like to execute a strategy, select it from the available strategies drop down and press the 

execute button.  Parameters such as Lot Size, Time In Force and Offset Size can be adjusted in the 
fields below. 

Entry/Exit Setups 

 

MotiveWave™ comes with several built-in strategies that you use or modify to suit your needs: 
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1. Breakout – Creates buy/sell stop OCO (one cancels other) orders above and below the current 
market price.  This can be useful if you are expecting the price to shoot up or down in the near 
future and you want to get in on the trend. 

2. Fade – Creates limit OCO orders above and below the current market price.   
3. Brk Up/Fade Down – Creates a Buy Stop Order (above the current price) and a Buy Limit Order 

(below the current price) (OCO Orders) to enter the market long. 
4. Brk Dn/Fade Up – Creates a Sell Stop Order (below the current price) and a Sell Limit Order 

(below the current price) (OCO Orders) to enter the market short. 
5. Bracket Exit – Creates a limit order to exit a position and a stop order as a stop loss.  Both of 

these orders are OCO orders. 
6. Scale Out – 2 – Creates two limit exit orders and two stop loss orders to scale out of a position. 
7. Scale Out – 3 – Creates three limit exit orders and three stop loss orders to scale out of a 

position.  

Entry/Exit strategies can be managed by clicking on the edit button  to show the dialog below. 

Manage Entry/Exit Strategies Dialog 

 

Click on the New button to create a new strategy or select an existing strategy and click on the Edit 
button.  The Entry/Exit Strategy Dialog will be displayed to allow you to configure Entry and/or Exit 
orders for this strategy. If it has both types of orders, the exit orders will be created when the entry 
orders are filled.  The following fields apply to this dialog: 

1. Name – This is the name of the entry/exit strategy and will be displayed in the drop down 
2. Absolute Offset – By default the offset will be multiplied by the Offset Size in the Entry/Exit 

panel.  If you specify an absolute offset the offset (ticks) will be used as is.  
3. Offset – This is the distance (in ticks) from the current price.  If the absolute offset is not checked, 

this value will be multiplied by the offset size in the Entry/Exit panel.  
4. Lots – This is the number of trade lots that will be setup as the quantity for the order.  This 

number will be multiplied by the Lot Size field in the Entry/Exit panel. 

Entry Orders 

You can specify up to five entry orders for the strategy.  Each entry may have one or two orders.  If two 
orders are specified, then these orders will be submitted as an OCO (One Cancels Other) pair.   
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Entry/Exit Strategy Dialog 

 

Exit Orders 

Similar to the entry orders, you can specify up to 5 exit orders.  If this strategy has entry orders, then 
these orders will be created after the corresponding entry order has been filled.  Each exit can have a 
limit (profit taking order) and a stop/trail order (stop loss order).  These orders will be submitted as an 
OCO (One Cancels Other) pair.  If Auto Adjust Size is checked, the lot size will be adjusted to match the 
currently open position. 

Entry/Exit Strategy Dialog – Exit Orders 
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4.5.7 Preferences 

The behavior and appearance of orders can be modified from the Preferences Dialog (Configure -> 
Preferences from the Console menu bar).  Click on the Orders tab 

1. Price Axis Trading – Enables or disables the ability to trade from the price axis 
2. Buy/Sell Box Trading – Enables or disables the ability to trade from the Buy/Sell boxes 
3. Use Pips for Attached Orders – Indicates if pips vs price should be used when determining the 

offset from the parent order. 
4. Confirm Closing Positions – Displays a confirmation dialog when clicking on the close button for 

a position. 
5. Send Email on Filled Order – Sends an email to the configured email address when an order is 

filled.  Note: you must configure your email settings (see Email tab) 
6. Send Email on Rejected Order – Sends an email to the configured email address when an order is 

rejected.  Note: you must configure your email settings (see Email tab) 
7. Create Order – Mouse click to create (but not submit) an order 
8. Show Order Ticket – If checked, the Order Ticket dialog will be displayed when creating an order. 
9. Auto Submit – Mouse click to create and submit an order (double click by default) 
10. Price Axis Key Modifiers – This section may be used to customize what types of orders may be 

created from the price axis. 
a. Default (No Key) – defines the type of order created when the mouse is clicked with no 

modifier key 
b. Shift Key – defines the type of order created when the mouse is clicked while pressing the 

Shift Key 
c. Ctrl Key – defines the type of order created when the mouse is clicked while pressing the 

Ctrl Key 
d. Ctrl + Shift Key – defines the type of order created when the mouse is clicked while 

pressing the Ctrl and Shift Keys 

andrey
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Order Preferences 

 

4.6 Depth Of Market (DOM) 

MotiveWave™ provides a Depth of Market (DOM) feature that allows you to see bid and ask prices/sizes 
beyond the best bid and best ask provided this is supported and permissioned from your broker/data 
service.  Depth of Market can be accessed as a panel on a chart, a panel in the console or from a 
separate DOM window (File -> New -> New DOM Window from the Console menu bar). 

The following screen shot shows an example of a DOM window.  Current position information can be 
found at the bottom of the window.  The table area contains several different columns which are 
configurable from the Preferences dialog. 

1. P/L – Displays what the profit/loss would be for your open position at each price interval.  Profit 
levels are displayed with a light blue background, losses show in pink. 

2. Orders – Shows active orders.  Sell orders are in the left Orders column, buy orders are in the 
right Orders column.  The example below shows a limit sell order for 1 contract on the right hand 
side.  You can click and drag the label to adjust the limit price or cancel the order by clicking on 
the ‘C’. 

3. Bid – shows the current bid sizes at each price level 
4. Price – This is the price ladder.  It shows prices in increments of 1 tick.  The last price has a dark 

blue background and shows the last traded size.  Best bid and best ask prices have yellow and 
green backgrounds.  Day high and day low have blue and red backgrounds. 

5. Ask – shows the current ask sizes at each price level 
6. Histogram – Displays historical price action at each price level.  This column will update as live 

trades are made. 
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DOM Window 

 

4.6.1 Trading From the DOM 

By default the DOM is locked, this prevents trades from being placed directly from the table.  Click on 

the Lock/Unlock  button on the tool bar to enable trading from the DOM table.  Limit and stop orders 
can be placed by clicking on the Bid and Ask columns.  You will notice the mouse cursor changes when 
you move it over the bid and ask columns: 

1. Buy Limit  - This cursor will display over the Bid column and below the current best bid price.  
A limit order will be placed with the given quantity when a row is clicked with the left mouse 
button. 

2. Buy Stop  - This cursor will display over the Bid column and above the current best ask price. 
A stop order will be placed with the given quantity when a row is clicked with the left mouse 
button. 

3. Sell Limit  - This cursor will display over the Ask column and above the current best ask 
price.  A limit order will be placed with the given quantity when a row is clicked with the left 
mouse button. 

4. Sell Stop  - This cursor will display over the Ask column and below the current best bid price.  
A stop order will be placed with the given quantity when a row is clicked with the left mouse 
button. 
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DOM Orders 

 

Order Combinations 

Other types of order combinations can be created by choosing a different option from the order type 
drop down on the tool bar.  The following example shows the Limit + Stop/Limit option.  A limit order 
will be placed and a stop/limit order will be appended as a bracket order.  

DOM Order Types 

 

In the example below, the Limit + Stop/Limit option has chosen.  The cursor will display LMT SL when 
hovering over the Bid/Ask columns.  One left mouse click will create a limit order at that price and attach 
a stop and limit order above and below the current price. 
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Placing a Limit + Stop/Limit Order 

 

Adjusting Orders 

The price of a stop or limit order can be adjusted by dragging the order label up or down.  The order 
ticket dialog can be displayed by double clicking on the order label.  From this dialog you can change 
other attribute such as the Time In Force or the order quantity.  An order may be cancelled by clicking on 
the ‘C’ button to the right of the order label. 

Adjusting Orders from the DOM 

 

4.6.2 Position Panel 

The panel at the bottom of the DOM displays information on your current position and provides 
management options.  It has the following elements: 

1. Position – Current open position.  This is displayed as quantity@average entry price.  A blue 
background indicates a long position (red for short) 

2. P/L – Current profit/loss.  Blue background for profit, red for loss. 
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3. Spread – Difference between the bid and ask price 
4. Account – account to use for placing orders 
5. Flatten Button – Closes the open position at market price 
6. Cancel All Button – Cancels all active orders for this instrument 
7. Reverse Button – Reverses the currently open position at market price 
8. Buy Mkt Button – Buys at market price using the quantity at the top of the DOM 
9. Sell Mkt Button – Buys at market price using the quantity at the top of the DOM 

Positions Panel 

 

4.6.3 Centering 

In an active market, bid and ask prices may change quite rapidly.  In some cases these values may 
appear above or below the current price ladder.  The price ladder will automatically center itself in 5 

second intervals, but you can manually re-center the DOM prices by clicking on the Re-Center  button. 

4.6.4 Preferences 

DOM preference can be adjusted by choosing Options -> DOM Preferences from the top menu bar.  

Alternatively, click on the Preferences  button on the tool bar.  This dialog has the following fields: 

1. Rows – number of rows to display in the DOM table 
2. Time In Force – expiration for orders placed through the DOM 
3. Table Font – Font size for the table rows 
4. Show Quantity Selector – toggles the display of the bar that allows you to quickly choose a 

preset quantity 
5. Show P/L Column – toggles the display of the P/L column in the DOM table 
6. Show Histogram – toggles the display of the histogram in the DOM table 
7. Show Order Ticket Window – if enabled the order ticket dialog will be displayed when creating 

an order from the DOM 
8. Double Click to Place Order – if enabled a double click (instead of a single left click) will be 

required to create an order from the DOM 
9. Show Grid – shows the outline around each cell in the DOM table 
10. Show Totals – displays the totals bar at the bottom of the table 
11. Show Entry/Exit – toggles the display of the Entry/Exit strategies panel at the bottom of the 

DOM 
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DOM Preferences 

 

4.7 Option Chains 

Note: Option Chains are not available in the Trade or Analyst Editions 

Groups of options (Stock and Future Options) can be managed from the Option Chain panel in the 
Console.  If your broker supports options, you will see an “Options” page at the bottom of the Console 
window. 

An option chain panel enables you to see the available options organized by strike price for a given 
expiry date.  In the example below we are showing available options for AAPL that expire on May 23, 
2014.  By default 20 options (configurable) are displayed that are nearest the money.  For convenience, 
a black divider line shows where the current price is trading for the underlying symbols.   

Buy and sell orders can be placed directly from the option table by clicking on the Buy/Sell buttons that 
are next to each Put/Call pair.  Current positions and profit/loss are also visible on the table for each 
option. 

Option Chain 
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4.7.1 Placing and Managing Orders 

The easiest way to place a limit or stop order is to click on the Buy or Sell button next to the call or put 
option that you would like to trade.  When you click on this button an Order Ticket dialog will appear 
that will enable you to adjust the order.  Defaults such as Account, Quantity and Time In Force can be set 
at the bottom of the panel. 

Option Chain – Placing Orders 

 

Open orders can be canceled by clicking on the ‘C’ button next to the order.  All open orders in the 
option chain can be cancelled by clicking on the Cancel All button in the bottom right corner. 

Market orders can be placed by using the buttons in the bottom left corner.  These orders will be placed 
on the put/call option that is selected in the table above. 

If you have open positions, these can all be closed by clicking on the Flatten button in the bottom right 
corner. 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 166 of 190 

 

Option Chain – Managing Orders 

 

4.7.2 Preferences 

Preferences for the Option Chain can be modified by clicking on the Preferences  button in the top 
right corner.  This dialog has the following elements: 

1. Max Rows – Maximum number of rows to display for the option chain.  Click on Show All Options 
to display all available options 

2. Show Calls/Puts – By default both calls and puts are displayed in the table.  This drop down 
allows you to choose Calls or Puts or both. 

3. Table Font – Font and size for the text displayed in the table 
4. Show Grid – Displays a border around each cell in the table 
5. Sort Descending – Sorts descending by strike price 
6. Show Order Ticket – Shows the order ticket dialog when placing a market order 
7. Show Order Panel – Shows the section at the bottom of the option chain for managing orders 
8. Show Quote Panel – Shows the quotes for the underlying symbol at the top of the panel 
9. Update Button – Applies these changes and closes the dialog 
10. Call Columns Button – Click on this button to choose the columns displayed for Call Options 
11. Put Columns Button – Click on this button to choose columns displayed for Put Options 
12. Save Defaults Button – Saves these settings as the default for other Option Chain panels 
13. Cancel Button – Cancels changes and closes the dialog. 
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Option Chain Preferences Dialog 

 

Call and Put columns can be adjusted by clicking on the Call Columns or Put Columns button (see dialog 
above).  The columns available will depend on what is supported by your broker.  The dialog below 
shows available columns for Tradier Brokerage. 

Choosing Call/Put Columns 
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5 Chart Groups 

Note: This feature is not available in the Trade and Analyst versions of MotiveWave™ 

Chart Groups provide a convenient way to organize charts in one window.  A Chart Group is essentially 
another Console window and uses the same docking framework to layout pages. 

Choose File -> New -> Chart Group from the Console menu bar to create a Chart Group. 

Create Chart Group 

 

Enter a unique name for the Chart Group from the New Chart Group dialog and click the OK button to 
create the group. 

New Chart Group Dialog 

 

The follow screen shot shows the default layout for a Chart Group when it is first created.  The default 
layout includes two pages: Charts and Charts 2. 
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Chart Group – Default Layout 

 

To open or manage existing Chart Groups, select File -> Open -> Chart Group from the Console menu 
bar: 

Open/Manage Chart Groups 

 

When you close a chart group (by clicking on the ‘X’ button in the top left corner), the group is not 
deleted but still exists in the repository.  If you want to permanently remove a Chart Group, select it in 
the Manage Chart Groups dialog and click the Remove button. 
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Manage Chart Groups Dialog 

 

5.1 Changing Chart Group Layout 

Since a Chart Group is essentially another Console window, see the section: Changing the Default Layout 
for details on how to configure a custom layout. 
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6 Scanner 

Note: This feature is only available in the Ultimate Edition 

MotiveWave™ has a built-in scanner for looking for trade setups across a given set of instruments and 
bar sizes.  There three types of patterns that you can search for: 

1. Elliott Wave – Elliott Wave patterns such as Wave 2, 3, 4, 5 and Wave E (in a triangle) 
2. Gartley – Harmonic patterns including all XABCD type patterns, AB=CD, 5-0 and Alternate AB=CD 
3. Study Conditions – Criteria based on study values 

When you first start MotiveWave™ you will see a page at the bottom of the window named Scan.  Click 
on the page tab to show the screen below.   

Scan Page 

 

6.1 Creating a Scan (Gartley Scanner) 

If you would like to create a new scan, choose –New Scan—from the –Choose Scan—drop down or press 
the New Scan button on the right hand tool bar of the scanner panel (see screen shot above).  This will 
open a wizard that will guide you through the process of creating a scan. 

New Scan 
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The screen shot below shows the first page of the scanner wizard.  Enter a name for the scan and select 
the type of scanner from the drop down below.  In this example, we will choose Gartley as the type. 

Scanner Wizard Page 1 

 
 
On the next page of the wizard, you will be prompted to select 1 or more instruments and/or watch lists.  
If a watch list is chosen, all of the instruments that are in the watch lists will be included in the scan.  The 
order of the instruments and watch lists will be considered when the scan is executing. 

Scanner Wizard - Instruments 

 

Click on the Add  button to add a bar size to the list box.  Any size linear bar or non-linear bar (ie 
Range, Renko, etc) may be added.  Check the Extended Data box at the bottom of the dialog to use data 
that is outside of regular trading hours. 
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Scanner Wizard – Bar Sizes 

 

The final page of the Gartley scanner wizard enables you to choose the type of Gartley pattern to search 
for as well as the historical data range where the pattern may occur.  If you would like to search for all 
forms of the XABCD pattern (ie Gartley, Bat, Butterfly, Shark, etc) then choose XABCD (All) as the 
pattern. 

Scanner Wizard – Gartley Pattern 

 

6.2 Executing a Scan 

The following screen shot shows the new scan ‘Gartley XABCD Patterns’ that we created above and the 
results from running executing it on the latest available data.  If you would like to execute this scan, 
select it from the drop down and press the Start Scan button (see below in the upper left scanner panel).  
The progress bar will show how far the scan is progressing (see upper right scanner panel below).  

Results will display in the table area of the scanner panel as they are found.  This table will display:  

1. Symbol – instrument where the pattern was found 
2. Bar Size – Bar Size the pattern was found on 
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3. Scan Time – When the pattern was found 
4. Pattern – The specific pattern that was found 
5. Score – Score rating: 

a. Yellow Ball – Fair Match 
b. Green Ball – Good Match 
c. 2 Green Balls – Very Good Match 
d. 3 Green Balls – Excellent Match 

To display a scan result in the chart panel below left mouse click on the table row.  Note: this will only 

work if the Link  button is selected (see top right button area for the scanner panel below) 

The results displayed in the scanner table are unnamed analyses that are kept in computer memory.  If 
not explicitly saved, these analyses will disappear the next time you execute the scan or if MotiveWave™ 
is restarted.  When one of these results is opened in a chart window or panel, you may save the analysis 

to the repository by clicking on the Save  button (see tool bar). 

You may find that the full pattern that was found is not entirely visible when you display it in the chart.  
Click and drag the time axis to the right to zoom out or select a higher bar size. 

Scanner Results 

 

6.3 Editing a Scan 

You can edit a scan to change its instruments, bar sizes or criteria.  Select the scan from the drop down 

in the scanner panel and click the Edit  button from the button area in the top right corner of the 

panel.  Alternatively, click on the Manage Scans  button to open the Manage Scans dialog. 
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Edit Scan 

 

The Manage Scans dialog enables you to create, open, edit, rename or remove existing scans.  Select a 
scan from the list area and use the buttons on the bottom of the dialog. 

Manage Scans Dialog 

 
Edit Scan Dialog 

 

6.4 Elliott Wave Scanner 

The example shown above is for the Gartley scanner.  You can also search for Elliott Wave patterns by 
choosing Elliott Wave as the type when you create a new scan.  Selecting instruments and bar sizes is 
the same for all scan types. 
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New Elliott Wave Scan – Page 1 

 

On the Specify Criteria page you can choose the Elliott Wave pattern that you are searching for.  The 
following patterns are currently supported: 

1. Wave 2 – This will search for an Elliott Wave pattern when the top level wave is currently in a 
Wave 2.  Wave 2s are commonly used as trading setups since wave 3 tends to be the longest 
wave. 

2. Wave 3 – Finds patterns where the top level wave is currently in wave 3 
3. Wave 4 – Finds patterns where the top level wave is currently in wave 4 
4. Wave 5 – Find patterns where the top level wave is currently in wave 5 
5. Wave E (Triangle) – Finds patterns where the top level wave is in wave E of a triangle 

The Decompose Levels specify how many levels down the top level wave should be decomposed in to 
smaller waves.  Choose Decompose All to decompose the wave to all possible levels. 

The Minimum and Maximum bar settings can be used to define the historical data range.  If you check 
Use All Available Data MotiveWave™ will load all data from the local database. 

Elliott Wave Scan Criteria 
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The following screen shot shows the results of searching for a Wave 2 pattern.  To view a particular 
result, click on the row in the results table.  You may need to zoom the chart out to see the full pattern.  
In this case we have changed the bar size from 15 min to 1 hour and compressed the bar width by 
dragging the time axis to the right. 

Elliott Wave 2 Search Results 

 

6.5 Study Scanner 

The study scanner enables you to search for study conditions that include 1 or more studies.  When you 
create a new scan, choose Study as the type from the Type drop down.  Selecting instruments and bar 
sizes is the same for all scan types (see Creating a Scan (Gartley Scanner) section for details). 
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Study Scanner – Page 1 

 

On the Choose Studies panel, you can select one or more studies to include as part of the scan.  Click on 

the add study  button to add a study to the list box below.   When you click this button, you will be 
able to search for the study that you want to add and configure its settings (see following screen shots).  

Choose Studies Panel 
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Add Study Dialog 

 
Configure Study 

 

In the screen shot below, we have added one study to the scan, RSI(C,14).  Additional studies could be 
added by clicking the add button.  In this example, we are just going to work with one study. 
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The last page of the scanner wizard asks you to define the criteria for evaluating the scan.   Click on the 

add condition button to add a condition to the list.  There are two types of evaluation methods:  

1. All – In this method, all conditions defined on this page must be met in order for it to be 
considered a match.  This is the default evaluation method. 

2. One or More – In this method, only one of the conditions defined on this page must be met for it 
to be considered a match for this scan 

Study Criteria 

 

In the Study Condition dialog (see below) you can define a condition based on a variable that is 
generated from one of the studies you defined.  A variable may be compared against a specific value or 
compared against another variable.  The fields in this dialog are as follows: 

1. Study – Choose the study that you configured on the Choose Studies page 
2. Bar Index – In most cases the comparison is done with the current bar, but you may choose 

historical bars by choosing a specific index  
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3. Variable – This field will be populated when you choose the study.  Each study will export 1 or 
more variables.  You can see these variables in the Cursor Data Window/Panel  

4. Operator – This is the comparison operator for comparing the variable to the value.  Valid 
options include:  > (greater than), >=, < (less than), <=, = , Crosses, Crosses Above, Crosses 
Below 

5. Relative Comparison – Indicates if the variable should be compared against a specific value or 
against another variable. 

6. Value – If not a relative comparison, this field will contain the specific value you are comparing 
against.  

Add Study Condition Dialog 

 

If you checked the Relative Comparison option, the dialog will change to allow you to choose a study and 
variable for comparison.  The Price Bar option allows you to compare to the Open/High/Low/Close 
values of the price bar. 

Add Study Condition Dialog – Relative Comparison 

 

The screen shot below shows the results of running this scan.  In this case we only found one result 
where the RSI value is greater than 80. 



MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 182 of 190 

 

Study Scanner Results 
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7 Strategy Back Testing 
Note: This feature only available in the Ultimate Edition  

Strategy back testing is a special type of historical testing that allows you to determine how a strategy 
would have performed if it had actually been run during past historical time periods and market 
conditions. It does not guarantee how your strategy will perform in future market conditions, but will 
allow you to identify any potential issues or vulnerabilities against past market conditions. This allows 
you to ‘test’ and tweak your strategy without having to place actual trades. See the Wikipedia page on 
strategy back testing for more information. 

MotiveWave™ has highly advanced strategy back testing options through our Strategy Optimizer. The 
default layout of the MotiveWave™ Console has a page called Optimize (see bottom of the console 
window). Click this tab to show the strategy optimizer page. 

Optimizer Page - Console 

 

7.1 Creating a Strategy Analysis 

From the Optimize tab of the Console, click on the New Analysis button (see screen shot above). This 
will launch a wizard that will walk you through the process of creating an analysis of your selected 
strategy. 

MotiveWave supports 3 types of Strategy Analysis: 

1. Back Test - This option enables you to execute your strategy with specific settings over a given 
set of instruments and a specific bar size/time frame. This can be useful to determine how your 
strategy may have performed with past data and specific settings. 

http://en.wikipedia.org/wiki/Backtesting
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2. Optimize - The profitability of a strategy will vary depending on how it is configured. This option 
will enable you to specify a range of settings for the strategy and test many different 
combinations of these settings to determine which combination is "optimal". 

3. Walk Forward - Sometimes knowing the optimal settings for a specific range of data is not 
enough. Just because a strategy performed well for a specific bar size and time frame does not 
guarantee that it will continue to perform well in the future. Walk forward testing helps to 
mitigate this problem by stepping forward in time after every iteration of a time frame. 

The following screen shot shows the first panel of the New Strategy Analysis wizard. From here you can 
choose your strategy and specify the type of analysis you wish to perform. 

New Strategy Analysis – Page 1 

 
 

7.1.1 Strategy Settings Panel 

Once you have chosen the strategy and analysis type, click on the Next button to specify the settings for 
the strategy. If you chose Back Test, then you will just need to specify the specific settings for this 
strategy (see below). In this case we have chosen the "MA Cross Strategy": 
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MA Cross Strategy Settings 

 
 

Alternatively, if you chose Optimize or Walk Forward as the type, the next page of the wizard will look 
more like the following screen shot. This panel will enable you to specify the range of possibilities for the 
configuration of the strategy. MotiveWave™ will build combinations of the strategy settings based on 
this input. 

Optimize/Walk Forward Strategy Settings 

 
 

7.1.2 Choose Instruments Panel 

The next page of the wizard allows you to choose the set of instruments (symbols) for the analysis. A 

specific set of instruments may be chosen by clicking on the Add Instrument  button or the Search 

Instrument  button. Additionally, you may specify one or more watch lists to specify a group of 
instruments. 
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Choose Instruments Page 

 
 

7.1.3 Data Settings Panel 

If you choose Back Test or Optimize as the analysis type, then your data settings panel will look like the 
following. This panel allows you to choose the range of data and bar size for the analysis. Ideally you 
should use historical tick data (see Source Data field) for the analysis since will give the closest 
approximation of a real world test. Unfortunately not all brokers or data services provide this data (or 
enough of it). In these cases you can generate ticks from either the source data or 1 minute bars.  

Data Settings 

 

The walk forward data settings are a little bit different. Two more parameters are available to define the 
Optimize Period and Walk Forward Period. Optimize Period defines the size of the optimization window 
(the number of days to include in each walk forward iteration). If the Anchor option is enabled, the Start 
Date will remain fixed for each iteration. Effectively, this means that the optimize period will increase by 
the walk forward period each walk forward iteration (ie: 60, 90, 120 etc days in this example).  
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Data Settings – Walk Forward Testing 

 

7.1.4 Execution Settings Panel 

Execution settings specify the runtime behavior for the analysis.  Commissions can be included in the 
profit/loss calculation and can be configured from the Console menu bar (Configure -> Commissions).  
Slippage can also be enabled to account for market orders.  During periods of lower volume market 
orders may not be filled at the current bid/ask prices.  This parameter assumes that the order will be 
filled the given number of ticks away from the bid/ask price. 

Execution Settings 

 

7.1.5 Optimizer Settings Panel 

If you chose Optimize or Walk Forward as the analysis type, then you will see the Optimizer 
Settings panel as the last panel in the wizard. MotiveWave currently supports two types of optimizer 
algorithms: 
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1. Exhaustive - this algorithm will evaluate all combinations of the strategy settings to find the 
optimal result. This algorithm will find the optimal settings for the strategy. This is a good option 
if the number of combinations is relatively low. 

2. Genetic - employs a natural selection approach to find an optimal combination without having 
to evaluate all possible combinations of the strategy settings. For more details on how this works 
see wikipedia: Genetic Algorithm. 

7.1.5.1 Exhaustive Optimization vs. Genetic Optimization 

There are many types of optimization. The most common types used for strategy optimization are 
Exhaustive Optimization and Genetic Optimization. Both types of optimization have benefits. It’s just a 
matter of figuring out which type of optimization is most appropriate for the results you’re looking for.  

7.1.5.2 Exhaustive Optimization 

Exhaustive Optimization will run through and test every possible combination of inputs to determine the 
absolute best possible performance solution. But, because it will run through every possible 
combination, running an exhaustive optimization can take a very long time. The time required to run an 
exhaustive optimization is dramatically increased when a large number of inputs or parameters are used 
in the search. 

To reduce the amount of time required to run the exhaustive optimization, you can limit the number of 
inputs or parameters used to a small number, or use genetic optimization instead. 

7.1.5.3 Genetic Optimization 

Genetic Optimization (or Genetic Algorithm Optimization) is based on the concept of biological 
evolution, or natural selection. In relation to trading strategy optimization, genetic optimization will start 
by randomly selecting a number of combinations to test. From those selected, it will determine which of 
those combinations have the best potential and discard the rest. Then it will continue to test the 
remaining ‘best potential’ combination candidates until it arrives at the close-to-best input or parameter 
performance solution. 

Because genetic optimization does not test every possible combination, it will not arrive at the absolute 
best possible performance solution, like with exhaustive optimization, but the time it takes to arrive at a 
close-to-absolute best performance solution is dramatically shorter. 

Genetic Optimization is best suited for running an optimization with many inputs or parameters.   The 
larger the sample size is, the longer it will take to complete the optimization, but if the sample size is too 
small, the genetic optimization results may be less accurate. 

http://en.wikipedia.org/wiki/Genetic_algorithm


MotiveWave™ 
User’s Guide 

 

 
 

Version 1.0.2 ©2014 MotiveWave™ Software Page 189 of 190 

 

Optimizer Settings 

 

7.2 Strategy Analysis 

Once you have created and executed a strategy analysis, you can look at the results in the strategy 
optimizer (see below). The analysis will contain one or more execution instances in the summary table at 
the top of the window. Select the instance that you want to view and it will be displayed in the panel 
below the table. 

Strategy Analysis Metrics 

 

The following screen shot shows an example of the Chart tab of the strategy analysis. This tab displays a 
visual representation of the executed trades that occurred for the selected execution instance. 
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Strategy Analysis Chart 

 

Several visual reports are available under the Reports tab. The available report types can be found in the 
Report dropdown. 

Strategy Analysis Reports 

 


